Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

SWTOR Launcher States login service is currently unavailable

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
SWTOR Launcher States login service is currently unavailable
First BioWare Post First BioWare Post

AkiraTi's Avatar


AkiraTi
09.23.2020 , 12:52 PM | #61
I want to level It was working fine around like 8 am CST and then later when I came back - the loop launcher is unavailable. There is NOTHING on our end we can do, it's on the server or login end I'm sure. As multiple people are experiencing the same issue not just one.

Punkadelic's Avatar


Punkadelic
09.23.2020 , 12:53 PM | #62
Seems to be working now, just waiting on the bstd one time password, along with a gazillion others no doubt..

CommunityTeam's Avatar


CommunityTeam
09.23.2020 , 12:58 PM | #63 This is the last staff post in this thread.  
Hi folks,

The Connectivity issues have been resolved. You can now log back into the game.

Thank you for your patience.
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

LajosLila's Avatar


LajosLila
09.23.2020 , 02:36 PM | #64
Quote: Originally Posted by mnemonicanemone View Post
I just got in. Took my son to football practice and in the 10 minutes I was gone something changed. Although...I am required to download the entire game...again.
Same here. The fkn launcher just redownloading the whole game. With every videos and assets. Never happened to me before and I cant find any solution. So im just waiting and hoping, i will be able to login at the end. As a sub. Thank you bioware.

hocuspocus's Avatar


hocuspocus
09.24.2020 , 11:59 AM | #65
I am having the same error it takes me to the character selection screen and says that I launched on quick play with a download pending. It has been 2 days now and it still is not fixed and there is no alert about it. Know what's funny though is EA had no delay billing my credit card for my 6 month subscription today. I am so tired of the BS EA does to gamers. I have just gotten done on the phone with my Master Card disputing the charge as the service I paid for is not working AGAIN.

You never know what you can't do until you don't do it.

Bizhub's Avatar


Bizhub
09.24.2020 , 11:07 PM | #66
Stopped playing this game months ago only to come back and still have the same Problem...

amaniwolf's Avatar


amaniwolf
09.25.2020 , 05:15 AM | #67
My game still won't load up, it let's me put in my password and shows the loading screen with the image of Tau and the music plays then nothing. I'd just made a new character and was enjoying the x2 XP. I even contacted customer service before i knew about this thread. Come on people, give us a time table when this maybe resolved, don't just leave us without answers.
Your life is an occasion,....rise to it.

OwenBrooks's Avatar


OwenBrooks
09.25.2020 , 09:49 PM | #68
Quote: Originally Posted by hocuspocus View Post
I am having the same error it takes me to the character selection screen and says that I launched on quick play with a download pending. It has been 2 days now and it still is not fixed and there is no alert about it. Know what's funny though is EA had no delay billing my credit card for my 6 month subscription today. I am so tired of the BS EA does to gamers. I have just gotten done on the phone with my Master Card disputing the charge as the service I paid for is not working AGAIN.
workaround for your quickplay issue is to set the compatibility mode on the game shortcut to Windows XP Service Pack 3

detailed in the known issues sticky at https://answers.ea.com/t5/Technical-...4886775#M40174

Dusssst's Avatar


Dusssst
09.26.2020 , 12:53 AM | #69
Yeah, I'm also having same issues, too. Has anyone fixed theirs yet?