Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Maintenance: November 21st, 2019

STAR WARS: The Old Republic > English > General Discussion
Maintenance: November 21st, 2019
First BioWare Post First BioWare Post

JamesDTea's Avatar


JamesDTea
11.21.2019 , 09:26 AM | #11
Let's see they over looked a glitch that has been going on since launch of 6.0 again. There is a problem with the start of the Huttbreaker Mission on the Empire side of it but no matter how many times it is reported and even posted on this FORUM does it get fixed? I think it is time to let my sub go next month since no matter what the Cartel Market or some other BS is more important than game play. Eric i am the one who Messaged you on Twitter about the bug/glitch.
Master Kesslinger
Feel Free To Use My Link for 7 Days Sub Time and Other Items
http://www.swtor.com/r/kRWG6S

Master_Morak's Avatar


Master_Morak
11.21.2019 , 10:09 AM | #12
Quote: Originally Posted by TSCYoda View Post
Guys, are you serious???

Nearly 500mb of Data for this three little patches???

OMG...
The broken quest on Dantoinne "Pirates again" is still broken - what the hell are your devs doing the entire day?
Möge die Macht mit Euch sein

SerraShar's Avatar


SerraShar
11.21.2019 , 10:15 AM | #13
BW I hope you didn't miss that huge thread that keep getting buried in the BUG SECTION. There are many Bugs in this 'Expansion' and need some fixing . Lana Romance is one, but the companions are bugged (and I mean TAU and MALGUS) .
Balance in All Things
Andraste and the Maker want you to click referral linkhttp://www.swtor.com/r/fsSTHy
You know, if I could click you, you wouldn’t know a moment’s peace!

igor_gdynia's Avatar


igor_gdynia
11.21.2019 , 10:42 AM | #14
Eric, I don't consider UI to be fixed. Cooldown timer on buffs and debuffs is still broken!

2nd thing, why didn't you bring Dantooine daily/heroic conquest objectives back?

What do you do there guys?

DarkTergon's Avatar


DarkTergon
11.21.2019 , 11:06 AM | #15
Quote: Originally Posted by igor_gdynia View Post
Eric, I don't consider UI to be fixed. Cooldown timer on buffs and debuffs is still broken!

2nd thing, why didn't you bring Dantooine daily/heroic conquest objectives back?

What do you do there guys?
probably cause they nerfed conquest, and don't want to admit it....lol, if they roll that back, they might have to put back the other stuff...lol
No Idea if people use these, but if so, here's my referral link
http://www.swtor.com/r/jFXFFQ

EricMusco's Avatar


EricMusco
11.21.2019 , 11:09 AM | #16 This is the last staff post in this thread.  
Hey folks,

Totally understand the frustration around some of the bugs still in-game following 6.0 that weren't fixed today. For transparency, today's patch was an urgent and small patch specifically to address an exploit (stats stacking almost infinitely in Story Mode Ops) and to continue to address connection issues with Tulak Hord. There is another patch coming in December that has a fair number of bug fixes in it. I will aim to do a pass ahead of its release (especially in the bug reports forum) to relay what you can expect for bug fixes in that update.

-eric
Eric Musco | Community Manager
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

JennyFlynn's Avatar


JennyFlynn
11.21.2019 , 12:39 PM | #17
Quote: Originally Posted by EricMusco View Post
Hey folks,

Totally understand the frustration around some of the bugs still in-game following 6.0 that weren't fixed today. For transparency, today's patch was an urgent and small patch specifically to address an exploit (stats stacking almost infinitely in Story Mode Ops) and to continue to address connection issues with Tulak Hord. There is another patch coming in December that has a fair number of bug fixes in it. I will aim to do a pass ahead of its release (especially in the bug reports forum) to relay what you can expect for bug fixes in that update.

-eric
Was going to ask about this, thanks.

Could you please say whether the reported bug here concerning Republic saboteur/loyalist options will be addressed in that December patch, or at least whether it's been acknowledged for a fix? Since such a choice greatly impacts the story, I'd love to see a fix for it before the next portion of the story is released.
--------{---({@ Defiant Devotion | Defying Destiny | SWTOR Prompt Oneshots @}}>---}-------

tuxedotservo's Avatar


tuxedotservo
11.21.2019 , 12:43 PM | #18
The requirement for 8 Solid Resource Matrix mats to craft a single green (274) Level 77 Resistive Armoring basically breaks crafting for tank armor in the game - and now we get to wait two more weeks for a fix?

I haven't seen any other green 77 craftable items that require any purple level mats - not to mention 8 of them. There is a reason the GTN on Star Forge has none of these - because that cost for a green armor is ridiculous.

Not that the same level Versatile Armor 77 has no pruple mat requirement, for comparison purposes.
--
tux

Braggalo's Avatar


Braggalo
11.21.2019 , 01:53 PM | #19
Hi,

since this patch the game does not recognize my sub anymore, I'm treated as free-to-play, not even subscriber anymore.
It's getting more and more annoying to be honest.
best
Braggalo

P.S.: Tulak Hord, Sub still runs 5 days, have been subbed for years and thus am AT LEAST preferred player since 2014 or so...
P.P.S.: edit: character screen tells me I'm subbed as does my homepage account, but when in game I have lost my guild, can't post in chat, money is gone.
P.P.S.: relogging twice has solved the issue, but this is distressing to understate it

Nee-Elder's Avatar


Nee-Elder
11.21.2019 , 02:55 PM | #20
Quote: Originally Posted by Braggalo View Post
Hi,

since this patch the game does not recognize my sub anymore, I'm treated as free-to-play, not even subscriber anymore.


P.S.: Tulak Hord, Sub still runs 5 days, have been subbed for years and thus am AT LEAST preferred player since 2014 or so...
P.P.S.: edit: character screen tells me I'm subbed as does my homepage account, but when in game I have lost my guild, can't post in chat, money is gone.
P.P.S.: relogging twice has solved the issue, but this is distressing to understate it
It's not because of today's hotfix patch, since it was also happening last week and a few days ago too. It started with 6.0 or 6.0.1 ....and it relates to what i & others have already reported both privately & publicly: https://www.swtor.com/community/showthread.php?t=972313

The "relogging twice" trick has indeed worked as a work-a-round for some players, but not for everyone.

This issue---which again has now been made public by your post & other posts--- is quite simply toon-breaking (and, from a certain point of view, also gamebreaking ... at least temporarily) .

Hopefully the Dev Team has time to hotfix it BEFORE December. I suspect they want to fix it ASAP, of course, but are hamstrung by a myriad of pending 6.0 issues (like Crafting reboot) combined with a possible need to overhaul existing 'groupfinder' code alltogether.

Either way, and i realize this is my personal choice: i certainly won't be using 'groupfinder' again until i see it addressed in a Patch Note; or at least some sort of reassurance from Eric M.
Never tell me the odds!