Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Kurtob Alliance Speeder

First BioWare Post First BioWare Post

Wodaz's Avatar


Wodaz
05.03.2017 , 10:49 AM | #1
After the patch yesterday the Kurtob Alliance speeder is not running at the correct speed. All of my other mounts move faster and I can even run in game faster.
"Wodaz here! I'm all about havin' fun. You know, get a couple cocktails in me, start a fire in someone's kitchen. Maybe go to SeaWorld, take my pants off. Anyway, I'm kinda known for my catch phrase WHAMMY!!!!!"

Aderes's Avatar


Aderes
05.03.2017 , 11:23 AM | #2
THIS!!!

Here's a video to prove it:

https://youtu.be/DsU8gGAJkg8
(‾‾Covenant of the Phoenix‾‾‾‾‾‾[|][‾/‾/‾/‾/][)

GrizzlyUK's Avatar


GrizzlyUK
05.03.2017 , 05:27 PM | #3
This +1

Just popped into the forums to check if anyone had reported this yet! While I'm happy to see that someone has indeed already reported this I'm not happy that my favourite 110% mount is suddenly slower than running!
CE VIP - Pre-ordered: 21st July 2011, Pre-Order Code registered: 01st August 2011 due to retailer error
CE registered: 17th December 2011, Subscribing since 21st January 2012

Marjia's Avatar


Marjia
05.03.2017 , 07:30 PM | #4
I came here to see if it was just me. Thanks for posting this. I also did a bug report in game.

Dakkongj's Avatar


Dakkongj
05.08.2017 , 04:01 PM | #5
There is definitely something wrong with it, and hopefully its a bug and not a feature/intended change. I'm pretty sure walking is faster then this vehicle right now, or it could be a perception thing since I'm use to the speeder going 110% rather then whatever speed it's currently going.

Update: Speeder Pilot II also has no effect on the vehicle.

EricMusco's Avatar


EricMusco
05.09.2017 , 07:47 AM | #6 This is the last staff post in this thread.  
I will have the team look into this, thanks for the reports.

-eric
Eric Musco | Community Manager
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

RubyRiver's Avatar


RubyRiver
05.09.2017 , 04:09 PM | #7
This only seems to be for Speeder Rank I. I have 110% on Speeder Rank III.

GrizzlyUK's Avatar


GrizzlyUK
05.10.2017 , 11:15 AM | #8
Quote: Originally Posted by RubyRiver View Post
This only seems to be for Speeder Rank I. I have 110% on Speeder Rank III.
As of early yesterday (Tuesday 9th May 2017) when using the Kurtob Alliance Speeder on any of my characters that have Speeder Piloting II none of them went faster than running speed. Haven't bothered to test with any of my characters that have Speeder Piloting III though, just figured that if the Kurtob Alliance Speeder was bugged with most of my characters it would also be bugged for all characters. I'll try and check with all of my characters when I get in-game later and post back with the results.

EDIT: Checked the Kurtob Alliance Speeder on each of my characters, those with Speeder Piloting II had no movement speed bonus but those with Speeder Piloting III did indeed get the expected 110% movement speed bonus.
CE VIP - Pre-ordered: 21st July 2011, Pre-Order Code registered: 01st August 2011 due to retailer error
CE registered: 17th December 2011, Subscribing since 21st January 2012