Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Dissappointed with Customer Support

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Dissappointed with Customer Support

Bazaluk's Avatar

12.13.2011 , 05:40 PM | #1
I have been emailing them for a week about my problem with downloading the game. I'm receiving the message 'Unable to retrieve patch data. Please check network connection.' which is stopping me from downloading anything.

So far the only solution they have offered me is to re download the launcher which I have obviously tried.
In their last reply to me they asked me to attach my dxdiag and log files for swtor which i did.

I waited two days for a reply only for them to send me this:

"Since the problem that you were having has been resolved, Iím closing your ticket."

My problem has NOT! been resolved at all.

I have been very patient and appreciative of the help they were giving me until now. Now I'm just very annoyed and disappointed.

onexsora's Avatar

12.13.2011 , 05:42 PM | #2
I have that problem aswell some times, but that is when my internet goes out for a moment, you see the pause button next to the patch bar? try pausing the download and unpausing to see if that helps, thats all i can think of to do since it worked for me.

Indurin's Avatar

12.13.2011 , 05:43 PM | #3
That's okay, I posted two threads in customer service asking the same question. The first got closed, the second deleted completely, neither one answered.

Packetdancer's Avatar

12.13.2011 , 05:45 PM | #4
Unable to Retrieve Patch is often shown mistakenly when your download speed drops below a certain point. If you see this happen and the launcher doesn't recover after 5-10 minutes, you can generally hit 'pause' on the download bar, wait briefly, and then start it again to restart the download.
Pahke Stardancer (Jedi Sentinel, Save Taris)
Writer, photographer, software engineer, GAMER.