Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Now that 3.0 is live when can we expect GSF fixes?

STAR WARS: The Old Republic > English > General Discussion
Now that 3.0 is live when can we expect GSF fixes?
First BioWare Post First BioWare Post

DamascusAdontise's Avatar


DamascusAdontise
12.09.2014 , 09:57 AM | #1
So now that 3.0 is live, and all the other major bug fixes have been put through, when can we expect GSF to be fixed? Apparently they have been actively looking at it for over a week, with that in mind I would like to know:

1.) What went wrong?

2.) When can we expect a fix?

3.) Will the fix include just things that broke in 3.0 or all the stuff broken for the last 7 months?
Ahazi Server Refugee (Beta - Shutdown) RIP TIE & Twin Ion
[Circle of Emnity] - Pincer - Ocula Pilot - The Bastion
New to GSF? Look Here!. // And Here!

AlexModny's Avatar


AlexModny
12.09.2014 , 10:35 AM | #2 This is the last staff post in this thread.  
Quote: Originally Posted by DamascusAdontise View Post
So now that 3.0 is live, and all the other major bug fixes have been put through, when can we expect GSF to be fixed? Apparently they have been actively looking at it for over a week, with that in mind I would like to know:

1.) What went wrong?
There was a code bug in 3.0 that broke how some of the abilities (such as Engine Suppression on EMP Missiles) check to see if the character has unlocked the required upgrade. This resulted in the character having the ability, the player using the ability but the ability not activating all effects because it didn't see the character having the upgrade.

2.) When can we expect a fix?
As of this moment the fix is slated for 3.0.1 but it hasn't gone through QA approval yet so if they find issues there is potential for a delay.

3.) Will the fix include just things that broke in 3.0 or all the stuff broken for the last 7 months?
The fix will just include the abilities that broke in 3.0 via this code bug. I will give updates on other GSF issues down the line as I have updates.

I apologize for this issue to all our flyboys and flygirls. Cheers!
Alex Modny | Assistant Designer
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]

Caernos's Avatar


Caernos
12.09.2014 , 11:24 AM | #3
Alex,

Thank you for your response, this is the kind of post and information I have been looking for. Thank you for making this a priority and working on it.

That said, we still need fixes for those other bugs. Sabotage probe has been broken for months, and tooltips for several components have been incomplete or wrong. I know you guys have a lot on your plate right now and taking care of the 3.0 bug is a huge help, but these other issues have been standing for a long time and need attention too.

Please do not take my post the wrong way, I am not trying to be negative. I am very happy to see that this 3.0 bug is getting attention and that a fix is coming (hopefully in 3.0.1 if it gets approved). I just want to make sure that those older issues are not forgotten again.

I apologize if my comments and words are rude, insensitive, offensive, or hurtful, that was not my intent with this post. If anyone is bothered by the content of my post, please let me know immediately so that I may edit accordingly. Furthermore, everything I have said in this post is my opinion and should not be taken as a fact, I am an individual and not a representative of the community and it should not be assumed that I speak for any group of players or people.

Thank you.

Spoiler
Cynfor Cinderheart and the Cinderheart Legacy: The Ebon Hawk
The FanFic Works of Caernos:
Red Invitation, Parents,
Beskar Bonds and Cinder Hearts

Ymris's Avatar


Ymris
12.09.2014 , 11:24 AM | #4
That's all I wanted. I guess I can stop flying my ship in circles around BioWare HQ now. Thank you!
Tensoring straight to hell!

DamascusAdontise's Avatar


DamascusAdontise
12.09.2014 , 11:35 AM | #5
Quote: Originally Posted by AlexModny View Post

1.) What went wrong?
There was a code bug in 3.0 that broke how some of the abilities (such as Engine Suppression on EMP Missiles) check to see if the character has unlocked the required upgrade. This resulted in the character having the ability, the player using the ability but the ability not activating all effects because it didn't see the character having the upgrade.

2.) When can we expect a fix?
As of this moment the fix is slated for 3.0.1 but it hasn't gone through QA approval yet so if they find issues there is potential for a delay.

3.) Will the fix include just things that broke in 3.0 or all the stuff broken for the last 7 months?
The fix will just include the abilities that broke in 3.0 via this code bug. I will give updates on other GSF issues down the line as I have updates.

I apologize for this issue to all our flyboys and flygirls. Cheers!

This answers all my questions and more! I truly appreciate the response, this is basically what I was looking for from the time I started rabble-rousing

IMO communication was the biggest thing that had me miffed (besides the bugs themselves) this gives me a very good idea of when to expect fixes.

Glad to hear its coming down the pipeline, likely in the next patch. Goodluck to those of you working on GSF and may the force be with your coders / testers!

Oh and im sure you guys have it well in hand, but if you have any questions that the GSF community can help with let us know. A lot of us can do stringent testing and tell you things that might take your staff a couple hours / days to find out.
Ahazi Server Refugee (Beta - Shutdown) RIP TIE & Twin Ion
[Circle of Emnity] - Pincer - Ocula Pilot - The Bastion
New to GSF? Look Here!. // And Here!

Ymris's Avatar


Ymris
12.09.2014 , 11:53 AM | #6
Oh, and. My birthday is next Tuesday. Just saying.
Tensoring straight to hell!

Verain's Avatar


Verain
12.09.2014 , 12:43 PM | #7
This is aces, thank you so much.
"The most despicable person on the GSF forum."

idnewton's Avatar


idnewton
12.09.2014 , 01:31 PM | #8
Quote: Originally Posted by AlexModny View Post

1.) What went wrong?
There was a code bug in 3.0 that broke how some of the abilities (such as Engine Suppression on EMP Missiles) check to see if the character has unlocked the required upgrade. This resulted in the character having the ability, the player using the ability but the ability not activating all effects because it didn't see the character having the upgrade.

2.) When can we expect a fix?
As of this moment the fix is slated for 3.0.1 but it hasn't gone through QA approval yet so if they find issues there is potential for a delay.

3.) Will the fix include just things that broke in 3.0 or all the stuff broken for the last 7 months?
The fix will just include the abilities that broke in 3.0 via this code bug. I will give updates on other GSF issues down the line as I have updates.

I apologize for this issue to all our flyboys and flygirls. Cheers!
This is what we want, this is what you need to do more of.

We like transparency, we like explanation. Perfection is great, but we're all human. We're not expecting you to be perfect, just to be open when you make mistakes and give us good information like this.

Thanks, step in the right direction.
PRE-ORDER ACCOUNT LEGACY LEVEL 50 LEVEL +55s: 24
ETERNAL WARRIOR CHEEVO POINTS: +31,000
Quote: Originally Posted by idnewton View Post
Negative language gets you disqualified? Oh I'm sorry, please wait while I contact your local 'safe space'

JattaGin's Avatar


JattaGin
12.09.2014 , 01:35 PM | #9
Now that's a proper dev reply! Thanks, Alex.

Ryuku-sama's Avatar


Ryuku-sama
12.09.2014 , 05:10 PM | #10
Thank you ALex. That's what I wanted. Proper communication. Explanation on the issues...

Now onto the slows broken for the last 6 months and EMP having a much shorter range??????????
"If it wasn't broken, we shall break it. If it is balanced, we shall beat it until slow and painful death follows. If it is overpowered, it is working as intended." - Bioware 2015