Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Ingame mouse sensitivity at 0%

STAR WARS: The Old Republic > English > Galactic Starfighter
Ingame mouse sensitivity at 0%

dvametragluposti's Avatar


dvametragluposti
11.05.2014 , 08:38 AM | #1
...is still to fast for GSF (even PvE/PvP sometimes get acceleration)!!!

I'm playing on one monitor @ 1080p with a fixed 1000DPI mouse and disabled Windows Mouse Accel. and 6/11 neutral speed setting.

Any possible config editing to help?

Ryuku-sama's Avatar


Ryuku-sama
11.05.2014 , 08:59 AM | #2
Quote: Originally Posted by dvametragluposti View Post
...is still to fast for GSF (even PvE/PvP sometimes get acceleration)!!!

I'm playing on one monitor @ 1080p with a fixed 1000DPI mouse and disabled Windows Mouse Accel. and 6/11 neutral speed setting.

Any possible config editing to help?
Lower your mouse to about 650-700 DPI.
"If it wasn't broken, we shall break it. If it is balanced, we shall beat it until slow and painful death follows. If it is overpowered, it is working as intended." - Bioware 2015

Asbetos's Avatar


Asbetos
11.05.2014 , 09:07 AM | #3
You should be able to lower the DPI in our mouse software (Logitech Gaming Software if you're using a better Logitech mouse). Also, what is your pooling rate? I play at 1600DPI with 1000 pooling rate at 1280x768 and it's perfect, for me at least.
The Progenitor
Darth Xinthos Skykiller <Retaliation>
Captain Zyka Skykiller <Sons of Anarchy>

Verain's Avatar


Verain
11.05.2014 , 09:08 AM | #4
You could go lower, but is that the root of the issue?

What position is your hand in on the mouse? Is it smooth and covering it, or is it arched upwards? Can you try the other? (in my experience, having my hand arched above the mouse is much more precise for me).


I've never understood the penchant for ramping mouse speed down- I think it plays quite well natively. The mouse movements in question are rather small as a result. If you've already disabled acceleration, I'd give different hand positions a try, see if that helps.

But yea, you can make it even slower.
"The most despicable person on the GSF forum."

dvametragluposti's Avatar


dvametragluposti
11.07.2014 , 12:33 PM | #5
As I said, it's a cheap-o Sithy mouse with fixed 1000dpi, can't change it, via software or hardware.

In normal PvE/PvP, sometimes there are some accel. bumps, but nothing serious. *Doesn't happen in other games (competitive games to be precise), so don't blame my setup*

What bothers me is that a 1000dpi mouse at zero mouse speed or acceleration, and 0% speed in SWTOR is so sensitive in GSF, and there isn't anything I can do, except change speed in Windows manually each time I go play GSF...

Just thought someone had similar issues here.

MaximusRex's Avatar


MaximusRex
11.07.2014 , 01:01 PM | #6
OP, mouse sensitivity has been an issue in this game since launch, it much more touchy than any other game I play. BioWare doesn't seem very interested in addressing it either, when I asked Musco about it during a livestream he basically said to go buy a fancy gaming mouse so I can make my own adjustments. The slider was also broken for a long time and didn't even allow you to reduce the setting. They just don't care about quality game controls.

dvametragluposti's Avatar


dvametragluposti
11.07.2014 , 04:28 PM | #7
Quote: Originally Posted by MaximusRex View Post
OP, mouse sensitivity has been an issue in this game since launch, it much more touchy than any other game I play. BioWare doesn't seem very interested in addressing it either, when I asked Musco about it during a livestream he basically said to go buy a fancy gaming mouse so I can make my own adjustments. The slider was also broken for a long time and didn't even allow you to reduce the setting. They just don't care about quality game controls.
My reasoning too. Srsly, the main input for this game is iffy. Years after launch...