Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Camera rotation speed increments bugged?

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Camera rotation speed increments bugged?
First BioWare Post First BioWare Post

E-Zekiel's Avatar


E-Zekiel
05.26.2014 , 06:44 PM | #1
Came back to the game a few weeks back and had to adjust the camera rotation speed down again. Moved it down to 6%. After some extreme aggravation today regarding the well-known "camera twitching bug" (you can google it)

I decided to move my sensitivity from 6% to 0%. I opened my options to find that it was already 0%. I did not set it to 0%, I set it to 6%.
To ensure it was in fact set to 0%, I then turned it up to 100% and back down to 0%. Despite the fact my game telling me it was already 0%, my camera was, in fact, moving slower. Now it is too slow for my tastes.

The biggest problem aside from the ongoing camera twitching problem is that camera rotation speed now only moves in increments of 26%. Or at least it goes 0%, 26%, 52%, 77%, 100%. None of these speeds are playable to me but 0%, and that is slightly too slow.

Jerba's Avatar


Jerba
05.26.2014 , 08:44 PM | #2
I can confirm this bug. It only occurs when you start changing the rotation speed; it is fine when you leave it alone.

When you get the bug, you can always reset the camera rotation speed by opening the file
C:\Users\UserName\AppData\Local\SWTOR\swtor\settings\AccountName_Account.ini
and deleting the line:
Controls_CameraRotationSpeed = 0.10000000149
Alternatively, you can change this number to a value that works best for you.

However, I hope that they fix it so that you can once again adjust the camera speed continuously without having to edit the config files.

Here are a few threads describing the same issue in the CS forums:
http://www.swtor.com/community/showthread.php?t=743160
http://www.swtor.com/community/showthread.php?t=743479
http://www.swtor.com/community/showthread.php?t=742732
It appears that this bug got introduced with patch 2.7.2, it is also present in GU 2.8 on the PTS.

TaitWatson's Avatar


TaitWatson
05.27.2014 , 09:50 AM | #3 Click here to go to the next staff post in this thread. Next  
I'll pass it along for investigation (if it's not already logged), thanks.
Tait "pariahloki" Watson
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

Daewan's Avatar


Daewan
06.03.2014 , 10:27 AM | #4
Any news on this, Tait? It's still really wonky and annoying. It goes so fast it can trigger motion sickness in some people.
Darth Squeek, Dark Lord of the Skittles, Revan Fanboy
<< Idiot :: Questions about SWTOR? SEARCH DULFY! :: Obligatory referral link: http://www.swtor.com/r/Kp7S8B
Loyalty is worth less.

Danylia's Avatar


Danylia
06.03.2014 , 10:51 AM | #5
It seems several other "camera settings" are bugged as well.
- deselecting Smart Camera will turn this option off. However, when selecting smart camera again, it remains turned off (tried relog and repair).
- Camera max distance cannot be any longer modified by 1% per step, instead each step changes the value by 4-5%.
Quote: Originally Posted by Rafkin View Post
Last nights group finder was a mess. The short version is that two of the people were really bad but the tank was pretty good. After we called it I asked the tank if he wanted to queue up with me. He said "I'm eleven and I have to go to bed".
The one guy who knew what he was doing was eleven years old.

TaitWatson's Avatar


TaitWatson
06.03.2014 , 01:40 PM | #6 This is the last staff post in this thread.  
It is something the team was aware of, but I don't have any ETA for a fix.
Tait "pariahloki" Watson
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

Jnaathra's Avatar


Jnaathra
12.28.2014 , 06:21 PM | #7
Quote: Originally Posted by TaitWatson View Post
It is something the team was aware of, but I don't have any ETA for a fix.
AKA NEVER! Still broken!

Kakisback's Avatar


Kakisback
03.16.2015 , 07:48 PM | #8
Still bugged.
Kakarrotx/Meleehealer/Brawlly/Trunkkss/Whatashocker/Asparaguss/Kakadot/Lettucce/Greenn/Radishz/Burdok

BrokenTangent's Avatar


BrokenTangent
04.19.2015 , 05:50 PM | #9
FYI this is still broken.

Editing the config file manually hasn't seemed to have any effect at all either.

Quite sad this still isn't fixed.

JMullane's Avatar


JMullane
04.23.2015 , 12:35 AM | #10
Still bugged. I've gotten more used to the current mouse rotation speed, but I still wish I could make it just a tad slower. But I know if I touch that bugged slider bar it'll just make things worse.

Any chance you'll get this bug fixed sometime before the 1-year mark that you publicly acknowledged it?