Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Titans of Industry mission doesn't contunue

mrfoughtforever's Avatar

01.11.2014 , 10:05 AM | #21
Quest still not advancing. I've tried all the steps outlined in this thread.

Genedril's Avatar

01.14.2014 , 03:21 AM | #22
Managed to get it to update by:

Get mission / starship to CZ / do dailes / do labs (exit location) / Starship to fleet / Priority Transport to CZ-198 /

I'm now on complete Meltdown. Strangly I was having a complete meltdown before I got to this point so it's nice to have BW validate the annoyance the quest was causing me.

Which part of that caused the fix I don't know - I do know that it didn't update until I used the Priority Transport. I'm guessing that the ticket with BW and their 'don't do non-class missions kkthnxbyebyehavefun' reply had nothing to do with it but who knows.....

Knobbyknees's Avatar

01.14.2014 , 07:55 PM | #23
Do the devs have any explanation for this, and can they at least let us know they are working to fix this bug?

Gambit-X's Avatar

01.25.2014 , 08:23 PM | #24
I did have this bug too.
I did the flashpoints and nothing changed.
Then i used the macrobinoculars at the notepad on the desk which is on the left side of the way that leads from ferry to the room with the fp-terminals, vendors etc.
After that the mission proceeded and told to get back to the contact.

VeryBlackRaven's Avatar

04.24.2014 , 04:41 AM | #25
I had the opposite issue with the quest:
1. Took the quest on the fleet
2. Traveled to CZ-198
3. Took all dailies and a weekly (didn't complete anything)
4. Went to reputation vendors
5. The quest said to return to the fleet, which I did
6. Quest complete

Telanis's Avatar

07.12.2014 , 03:52 PM | #26
I just had this. Traveled to CZ-198 with the Legacy perk, exited to my ship via the shuttle, flew to Ilum and back to CZ, exited, and went to rep vendor. Updated fine at that point.

thewitchdoctor's Avatar

07.14.2014 , 04:42 AM | #27
Quote: Originally Posted by Telanis View Post
I just had this. Traveled to CZ-198 with the Legacy perk ...
A lot of quests require you to arrive or depart in a specified manner (sometimes in a presumed manner) and will not update otherwise.

If it says, fly in your ship, that is the only way it will update, for example.
Good. Bad. I'm the twi'lek with the saber.

Zaldun's Avatar

01.17.2016 , 12:41 PM | #28
I got into same issue as the OP posted for the quest "TItans of Industry".
To solve this, go to the vendors inside the Office Terminal 1-A that is accesed from landing zone. Once getting inside, the quest advanced from "Travel to the CZ-198 Facility Terminal" to "Return to Moff Kresk" stage.