Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher not working

ThatRyanDude's Avatar

03.19.2014 , 06:34 AM | #1
Hello, since the new patch came up yesterday I have been unable to open the launcher. When I run the launcher I can see launcher.exe in the task manager, however it ceases to run after a few seconds and the launcher is never bought up. I have tried various fixes:

- Running as administrator
- Deleting patch folder
- Re-installing the launcher over the original
- Performing a clean boot
- Turning Anti-virus off
- Running LauncherRepairUtilityP1.76.2.exe
- Downloading through origin instead of from the swtor site

None of these fixes have worked and I am unsure where to go next. Please help!

Thanks in advance.

nooberwaffles's Avatar

03.19.2014 , 06:39 AM | #2
IIRC you need to open the game folder and delete the "patch" folder. I had that issue before and I think thta's what solved it.

OwenBrooks's Avatar

03.19.2014 , 06:44 AM | #3
have a look in say windows/syswow64 folder for another libcef.dll file if there is one there move it out of the common path and see if that sorts it

Edit - which Antivirus do you use ?

ThatRyanDude's Avatar

03.19.2014 , 06:51 AM | #4
I tried deleting the patch folder and had no success. Also there was no libcef.dll under windows/syswow64 folder, so no success there either.

Thanks for the help anyway!

OwenBrooks's Avatar

03.19.2014 , 06:53 AM | #5
Which AV do you use ?

Ones like say ESET and protocol filtering could cause something similar even if you think the AV is disabled

ThatRyanDude's Avatar

03.19.2014 , 06:56 AM | #6
I am using Avast, though it has never caused any problems with swtor before.

OwenBrooks's Avatar

03.19.2014 , 07:08 AM | #7
I am not aware of Avast causing that either

kaperskey and Eset yes -

Few other things to try , create a new windows administrator account and goto the game folder and run launcher.exe from there

The only other possible thing that may affect the launcher starting that I am aware of is to do with the TCPiP and Winsock stacks

Reset tcpip -
Reset Winsock -

ThatRyanDude's Avatar

03.19.2014 , 07:30 AM | #8
Creating a new administrator account worked, its now downloading. I'm guessing once it has downloaded it may work again on my normal account? I'd rather not have to switch users just for swtor >.<

Thanks for the help!

OwenBrooks's Avatar

03.19.2014 , 07:33 AM | #9
Back on the normal account later what you can try is

•Press the [Windows] Key + [R] at the same time.
•Copy the following in to the text box and press ok: %localappdata%

Look for Swtor folders and delete them

When you run the launcher from the game folders they should recreate, just like when you ran the game again under the new user account.

ThatRyanDude's Avatar

03.19.2014 , 12:16 PM | #10
Well swtor runs fine on the new account, however I still cannot get it working on the main account. Least it is playable in some form now.