Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Can't Log in to Character

AngusGibson's Avatar

03.10.2014 , 08:00 PM | #1
This is the first time activating my profile in a long time. I downloaded the game client today and logged in. For the record, I'm running Windows 8.1 on a brand new, high-end computer. When it gets passed the loading screen, all it shows is my character's face from really close up. No buttons to press, no log in choices, just my character with the interior of his ship in the background. Help!

AngusGibson's Avatar

03.10.2014 , 08:47 PM | #2
UPDATE: Still can't log in. Tried pressing CTRL+U. No good. Tried running in Windows 7 compatibility mode. No good. Wouldn't even go passed the launcher.

AngusGibson's Avatar

03.10.2014 , 09:13 PM | #3
UPDATE: Updated my graphics card driver and let nVidia Geforce Experience optimize my SWTOR game. Now it works like a charm! Problem solved!

OwenBrooks's Avatar

03.11.2014 , 01:27 AM | #4
If this happens again , on that screen with no buttons , press ALT + Enter and then set in-game gfx again