Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

platforming control problems

STAR WARS: The Old Republic > English > General Discussion
platforming control problems

DarkCarnage's Avatar

03.11.2012 , 09:33 AM | #11
i would like to now which jumping one giving poeple issues. i gotten aprrox. 90% of teh datacrons, the only ones i find i have issues with i'm a type 3 large body, but i can not fix between small cracks to get so far 2 datacrons easily. one i ahd to die to get, the next one idk how to get at this time. it in corlira(likely misspelled) under a platform and the only way to get to it is to walk in a crack on pile. which i'm to ig for.
Server: Shadow Hand ; Char: DarkCarnage SW
Guild: Hellions, i'm pretty easy to find, jsut follow the path of dead bodies, kocked up Sith ladies and crying Impiral soilders, bwhaahhaha.

Game-Hermit's Avatar

03.11.2012 , 09:47 AM | #12
Quote: Originally Posted by Salion View Post
I have a gripe about the Datacron farming. Most of them require platforming - jumping from object to object. However, the controls of the game are not set up to encourage success at these mechanics. When I press the spacebar to jump, 5 different things may occur. In order of likelihood:

1) There is no jump at all - my character just walks off of the platform.
2) She jumps a short distance with a short height.
3) She jumps a short distance with a high height.
4) She jumps a long distance with a short height.
5) She jumps a long distance with a long height.

I don't get to pick between these options. My testing has revealed that the option is sometimes affected by whether you are standing still or running, but it is inconsistently affected. Having sprint active makes the distances a little longer, but still has all 5 options. If the jump distances and heights are going to be variable, please allow me to actively choose between them, and please remove the 1st option, which happens most of the time, when the game just ignores my jump command.

A 2nd problem is that when I move forward into a raised platform that is connected to my current platform but the jump achieved is a short height, all forward momentum is changed to sideways momentum, and I end up moving sideways off of the platform I am on.

A 3rd problem is invisible walls in midair. I'll jump forward towards another platform, when suddenly, halfway there, my character changes direction and moves sideways at full-speed.

A 4th problem is changing strafing speeds. If I switch from left to right or vice versa, sometimes I'll suddenly go at twice the speed and fall of a platform.

Spending an hour on one datacron repeatedly falling off of the same platform is not fun.

Edit: I've now spend 90 minutes on a datacron without anything to show for it, I give up - until the controls are improved, it is not possible to grind out these datacrons.
You're doing it wrong. I haven't had any problems with the jumping. As for #1, that's a common problem that I've experienced in almost every game with platforming starting with the original Mario Brothers. You're trying to jump while you're too close to the edge.

Quote: Originally Posted by Salion View Post
A 2nd problem is that when I move forward into a raised platform that is connected to my current platform but the jump achieved is a short height, all forward momentum is changed to sideways momentum, and I end up moving sideways off of the platform I am on.
So why do you keep running forward? If you actually tried to learn from your mistakes you would have realized after the first time that you have to jump first, then move forward. If you jump while stationary and then move you go forward barely enough to get onto the platform. You get no sideways movement that way.

monkgryphon's Avatar

03.11.2012 , 09:55 AM | #13
Overall the jumping controls may be difficult, but it does not mean they are impossible.

Next you're going to complain about how you have to wait about 30 minutes for a balloon to show up then ride it for another 30 minutes on Tattooine for 2 more datacrons.

I have managed to adjust myself and actually try again and again until I got a ton of the datacrons. If you're taking 3 hours to get 1, then take a break and come back to it. You might see something different when you come back.

The only gripe I have with datacrons is the one on Alderaan, castle panteer. The passage doesn't allow body type 3 or 4 through it.

Derfmiolleh's Avatar

03.11.2012 , 10:07 AM | #14
I'm lucky. My guild does Datacron runs every so often and we use each other to help. If someone falls we duel and use abilities like Harpoon or storm (Vanguard) to get to each other from one hard spot to the next.

I think harpoon may pull a fatty through the Alderaan small door too maybe. I have seen others let themselves die then a partner rez them inside the door.

Shereena's Avatar

05.18.2013 , 01:05 AM | #15
Ive been having the same issue here, tried jumping to datacrons in Taris, my toon doesn't jump, she hits a wall or she jumps but lands on the ground underneath the platform she was supposed to land on. Issue still isn't fixed for some people....really makes the jumping for datacrons a pain and something i don't really wanna attempt...
My friend jumps to all the platforms with ease, her toon jumps high and lands where she is supposed to. This seriously needs to be fixed...

Jenzali's Avatar

05.18.2013 , 01:12 AM | #16
The jumping will always be consistent if you follow one easy trick. It's difficult to describe with words, though. But I have gotten every datacron in the game on first try without falling or failing, by employing this technique.

If W is your move forward and spacebar is your jump, do a "galloping" motion with your hand, such that W is pressed down a split-second before spacebar is, and then release spacebar as soon as possible with your thumb but keep W held down.

If you try to press W and spacebar at the same time often the jump will register without W so you will have no forward motion and fall off.

Note: For most datacrons it's helpful to turn off Sprint. Also, when jumping down from a higher platform to a lower one, aim your camera directly down so that you can see where the platforms are located in the XY plane rather than having to guess from a 3D angle.

I hope this helps. It has saved me hours, and I get every datacron on every character just because it's so easy and reliable now.
Dashto Vant - Arsenal Mercenary - The most dashing bounty hunter in the galaxy.

Aries_cz's Avatar

05.18.2013 , 01:37 AM | #17
Actually, jumping is pretty consistent. I will assume [W]=forward and [Space]=jump
You have these types (to my knowledge)
Holding [W] + [Space] = long jump (running and jumping)
[Space]+[W] = short jump (frog-like leap from spot)
[Space] = vertical jump (jumping in place)

I never had any problem with jumping to datacron, unless I missed the platform I tried to get to (Makeb +10 end)
I also helps to get on a speeder for longer jumps, and turning off sprint for more precise jumps

As to the difficulty, I managed to collect majority of the datacrons (45+) in maybe 5 hours of playing, and I am Datacron Master now
Supreme Commander of all riots yet to come
Without the darkness, how would we recognize the light?
Aries, admin of Czech/Slovak fansite
Check out my story videos or support me by clicking my Referral Link

Trellabyte's Avatar

01.13.2014 , 06:48 PM | #18
I may be late to this party, but I must disagree with those who say, "You're doing it wrong".

I have created 8 different characters, of which 5 are at Lvl 55. My first was a Sith Assassin, which had major platforming issues. My second was a Mercenary, which has every datacron in the game, and had no issues platforming. I also have a Vanguard with no issues.

However, I am currently playing a Scoundrel, and this character, 'Plain and Simple', WILL NOT JUMP CORRECTLY. There is something intrinsically wrong with this characters platforming abilities.

I am at a loss as to what is causing this. Is it Class, Species, Gender, Body type, Armor or a combination of attributes.
Whatever it is, it has absolutely nothing to do with keyboarding skills or the players experience level.

Hambunctious's Avatar

01.13.2014 , 08:19 PM | #19
A lot of the issues stem from client/server sync, and where the server thinks you jumped rather than from where you see yourself jumping.

I have a low ping with the server, but there are times when I hit spacebar well away from the edge of something, but I still fall off as if I never hit the bar. Other times it stutter steps before doing the jump.

I relate that to the same issue as the ability misfire bug. Where you use a power, but it doesn't fire, yet still puts it on cooldown.

valrdjem's Avatar

11.07.2014 , 05:42 PM | #20
I'm glad I'm not the only one. There is certainly room for improvements. I run into the issues of the OP, in that there is a delay between pressing space and the jump if moving. If sprint is on you end up taking a two or three extra steps (there seems to be no set number), and whole walking one or two. It is extremely frustrating. Adding a ledge grabbing function would be very helpful, or even a boosted jump via force or rocket boosters. I understand that the datacrons are supposed to add a challenge, however there is a difference between a challenge and fighting the controls.