Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Planted False Data in the Tarlam Hall of Records

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Planted False Data in the Tarlam Hall of Records

CrazyMcGee's Avatar

01.08.2014 , 12:24 AM | #1
So, trying to do this on Makeb. I thought I just needed to do [STAGE 1] False History first and then [STAGE 2] Landing Party. But I did that and didn't unlock the achievement.

Has anyone else done this? Is it bugged or am I missing something? Obviously I'm gonna try it again, but I thought maybe I had it wrong or something and I don't wanna beat my head against a brick wall.


02.16.2014 , 01:39 PM | #2
Got this issue too - already done this three times in a row - still not completed.
Got response from M0-T0 to submit bug report, but really can't trust this robot


02.26.2014 , 10:55 AM | #3
Solved this problem by soloing H2. It was hard on gas traps, but doable.
Got the Under-Moff speech after getting Landing Party and got achievement after completing it.

ibervang's Avatar

01.30.2015 , 04:10 PM | #4
it wont let me pres the panels fast enough. I press as just as i reach it, but because of biowares retarded implementions, i cant do it. Because of some retarde "activation time" I just end up dying, even though i use heroic moment.