Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher patch 2.51 update stuck

 

KiritoEmiya's Avatar


KiritoEmiya
12.17.2013 , 06:19 PM | #1
Alright, so I installed the 2.51 patch today, and it was running fine for a while, then at 'installing 99.78%' it froze. I've browsed over multiple solutions including restarting my computer, running repair utility and adding the program to my firewall, but nothing has worked. As a subscriber, I am decidedly ticked off because I'm losing game time and money. Can someone please help me resolve this?

On a side note, usually during updates, the client takes up a good chunk of my memory, but this time, there is barely anything registering on the Task Manager.

ultimodrgnrulz's Avatar


ultimodrgnrulz
12.18.2013 , 02:10 AM | #2
i am having the same problem its stuck at 96.99%

Serekos's Avatar


Serekos
12.18.2013 , 02:37 AM | #3
I have the same problem. It stucked at 100% since yesterday. It says updating, but nothing happens. I've reinstalled the launcher but not worked. Shall I reinstall the whole game?

http://kepfeltoltes.hu/131218/update...toltes.hu_.png
There is only the Force...

McVicar's Avatar


McVicar
12.18.2013 , 03:02 AM | #4
Hey All,

I decided to check my firewall, I have Kaspersky and set it to gaming mode. It's now downloading. If I don't update this in a few hours, assume it's working

ultimodrgnrulz's Avatar


ultimodrgnrulz
12.18.2013 , 04:33 AM | #5
i tried re-downloading the client and it wont even install now

Hjorvik's Avatar


Hjorvik
12.18.2013 , 04:40 AM | #6
I'm having the same issue. 100% downloaded and installed, but the game doesn't let me Run, nor Repair, or even try to change the settings. The only button that works is the Exit button.

Hasegava's Avatar


Hasegava
12.18.2013 , 06:42 AM | #7
In Russia the same problem. But in case all computer stuck on 85% and helping only restart button. As a subscriber from first day of this game I suppose it's not permissible. I hope that bioware reading all this post and solve this problem in a short period of time

Bstr's Avatar


Bstr
12.18.2013 , 09:01 AM | #8
Try a forced repair mentioned here:
http://republicshammer.swtorhost.com....php?t=9864197

If that does not help, look at the "Top 10" sticky at the top of the forum for how to fix this problem.
Bobuster: Sab. Guns. Robcase: Seer Sage Bosha: Def. Guard. ShepardCmd: S.S. Vang.
Bosat'ta: BG Merc. Bophia: Fury Maur. Borbend: Med. Op. Bo'ya: Dark. Sin
<Reformation> Ebon Hawk Server

Alpachie's Avatar


Alpachie
12.22.2013 , 12:45 PM | #9
yeah same with me gone through the whole process of running as admin repairing, force repairing, firewall checks safe mode yada yada yada and its still stuck at 99.85 why cant there be a physical download patch file to save this piss farting around it would make life easier

LetterAfterZ's Avatar


LetterAfterZ
12.23.2013 , 01:50 AM | #10
Just wanted to add that I also have this issue and have tried the restart, running fixlauncher.exe, deleting the bitraider folder, running the launcher as an admin, disabling all firewalls/virus scanners, running it on wireless and wired connections on different networks.

Mine is stuck saying 'Installing 97.44%' with a speed in brackets that seems to alternate between 512.00KB/s and 1024.00KB/s

Any other ideas?