Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Frozen "Loading" screen for a character

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Frozen "Loading" screen for a character

JadenZionKilljoy's Avatar

10.12.2013 , 03:25 PM | #1
Hey guys.

So I was trying to launch a game with my character and I'm stuck at the loading screen after clicking "Play". It always loads the loading bar to one point and stops there. I've been waiting for quite some time and nothing ever happens.

However, I can launch the game just fine with my other character, as well as with a new one.

The character was lastly on Tython.

What might be a problem is Tython itself, as least on my machine. I made a Jedi Knight just now, to test if the planet was the issue and low and behold - it won't load.

So, I can launch the game anywhere but at Tython?

I scanned the files and they appear to be fine. Perhaps a reinstall is the way to go? Let me know what you think, fellas.

GythralSWTOR's Avatar

10.13.2013 , 05:19 AM | #2
A few whamp rats died and the depleted population cannot cope with the new workload!

Red Eclipse seems very slow loading up the first character today!

Bstr's Avatar

10.14.2013 , 08:01 AM | #3
Try a few things mentioned on the Customer Service forum here: and

Most namely, do a "Repair" on a Launcher without the letters "ST" or delete the BitRaider folder on a Launcher that does. Both force the Launcher to scan all files and download any that are missing.
Bobuster: Sab. Guns. Robcase: Seer Sage Bosha: Def. Guard. ShepardCmd: S.S. Vang.
Bosat'ta: BG Merc. Bophia: Fury Maur. Borbend: Med. Op. Bo'ya: Dark. Sin
<Reformation> Ebon Hawk Server