Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Titans of Industry mission doesn't contunue

Brusim's Avatar

09.17.2013 , 03:33 AM | #11
It's unbelievable how customer service continues to disappoint me even when I think they can't disappoint anymore ...

This is their response to my ticket, they didn't even read my description so it's entirely not applicable. For scripted answers like this one they don't need actual people supporting, a program would be able to do it with much less cost.

"We are sorry that you have encountered an issue with your mission, however please be advised that we currently only offer support for class story missions.

We would kindly ask you to try the steps outlined below to resolve your issue, if the mission is still in your mission log. Unfortunately if you have abandoned the mission, we cannot provide assistance.

If your mission is located within a story area or flashpoint, please try leaving the phase by either:

• Walking out of the Phased Zone via the Portal Entrance (Green Gate)
• Reset the Phase by right clicking on your portrait and selecting reset phase /reset local phase.
• Using your Quick Travel ability to a Bind Point.
• Using your Emergency Fleet Pass.

You can determine if your character is within a story area or flashpoint as there will be a small gold bar on your screen with a character name on it. If you are on your own, this will display your character's name. By default this is located near the top center of your screen, if you have modified your UI you may have moved it. If the bar shows a character name which is not your own, please leave the instance and then reset it following the instructions above. Once you have reset the instance, re-enter, ensuring that you are the first person to enter (this will ensure that you are the “owner” of the instance, and your name will appear on the small gold bar).

Please be aware that you will not be able to successfully reset your mission when inside your personal ship or your hangar at a Spaceport, as these are considered story areas.

Once you have left the story area, please open up your Mission Log (you can do this by pressing the mission icon on your main menu bar or by pressing the Mission Log key, [L] by default) and then highlight the mission you need to reset and click on the reset button.

If this does not help fix your mission problem, or the mission is not located within a story phase or flashpoint, please try resetting the mission and then attempting it again.

Thank you for your patience and understanding, and we apologize for any inconvenience this issue may have caused.

Galactic Support is our specialty…

Is it really??? In my opinion it's just getting worse by the minute.
Do or not do, there is no try!

cosmicguru's Avatar

09.20.2013 , 09:02 AM | #12
Had the same problem as you. So I abandoned mission and accepted it again on republic fleet. Traveled to the Gav Daragon for the next part of the quest then In headed to CZ-198 facility (on my ship) and all worked well.
May the force be with ... me !

Brusim's Avatar

09.20.2013 , 03:10 PM | #13
I tried that several times before and never worked. But after the patch today I accepted the mission again, went over all steps and ti worked.

Problem solved.

Do or not do, there is no try!

KarmaForce's Avatar

10.10.2013 , 06:39 PM | #14
This problem still exists

EnCahgNeetoh's Avatar

10.11.2013 , 07:25 PM | #15
Quote: Originally Posted by KarmaForce View Post
This problem still exists
It sure does. It happened to a friend and myself today. We've tried the above steps and it won't continue.

BenKatarn's Avatar

11.18.2013 , 09:34 AM | #16
Can confirm that the quest still does not advance.
- = = The Atrias Legacy = = -
Aryne, Jedi Sentinel | Cayra, Jedi Sage | Kherra, Scoundrel | Khenna, Vanguard
Vertos, Sith Juggernaut | Zedas, Sith Sorcerer | Ysari, Sniper | Neith, Powertech

CommanderKeeva's Avatar

12.10.2013 , 10:25 AM | #17
I have tried these so far:

- Resetting the quest
- Abandoning the quest
- Picking it up from not one but two different flashpoint couriers
- Travelling to CZ-198 via ship
- Travelling to CZ-198 via terminal
- Travelling to CZ-198 via legacy skill
- Doing the Czerka Weekly
- Restarting the game
- Deleting the cache file
- Reinstalling the game
- Reinstalling my operating system
- Combinations of all of the above

And so far *nothing* I have made seems to have advanced to the damned quest beyond "Travel to CZ-198". Please advise?

EDIT: If this quest has indeed been bugged since August the Customer Service could have at least put it on the Known Issues List by November!

Javad's Avatar

12.13.2013 , 02:23 PM | #18
I can confirm that as of today, BioWare does not give a damn and the quest will still not progress.

Knobbyknees's Avatar

01.09.2014 , 09:11 PM | #19
I am stuck at this stage of the quest too. Traveled to CZ by ship, went to the terminal and the rep vendors, have even finished the weekly quest several times (so I've done both FPs). Won't advance past "Travel to the CZ-198 Facility Terminal".

DataBeaver's Avatar

01.10.2014 , 10:40 AM | #20
I had the same problem. The quest marker is behind the gate to the Czerka Corporate labs flashpoint. Taking the flashpoint mission didn't cause the quest to update, so I just left it alone and went to do other things. Fast forward a few days, and I did the Czerka Core Meltdown flashpoint for the weekly through group finder. After this I noticed that the Titans of Industry quest updated. I can't provide step-by-step instructions for getting the quest done, at least not right now, but maybe this can serve as a starting point to figuring it out.