Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Black screen since the update...

 
First BioWare Post First BioWare Post

RandolphWaite's Avatar


RandolphWaite
10.03.2013 , 03:06 AM | #11
The thing is, I've been playing the game since last year, the last time I logged in was, I think, less than a week ago, and I've never had any problems like this whatsoever before. If the drivers were sufficiently up to date a few days ago, then I don't see how they can be too outdated to run the same game now.

OwenBrooks's Avatar


OwenBrooks
10.03.2013 , 03:17 AM | #12
You could try a repair , if ST on the launcher , close launcher and delete the BitRaider Folder and start the launcher, if No ST run the repair on the launcher after login (lower left cog)

For either above also delete the file called DiskCacheArena

Blackscreen is usually video driver related though.

Edit - there is a sticky here with some things as well - http://www.swtor.com/community/showt...php?t=498597#4

RandolphWaite's Avatar


RandolphWaite
10.03.2013 , 03:17 AM | #13
I gave updating the drivers another try, only this time I completely uninstalled the drivers first and reinstalled them with a newer version - that seems to have worked, and the game is running again now (fingers crossed). I'm still not entirely sure how this all happened, but it's sorted now. Thanks for all your help.

OwenBrooks's Avatar


OwenBrooks
10.03.2013 , 03:19 AM | #14
Just glad to hear it is working for you again

Beesodd's Avatar


Beesodd
10.03.2013 , 03:19 AM | #15 This is the last staff post in this thread.  
Thanks for the update. It's certainly an odd situation, but it's good to hear that it's sorted now.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.