Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Black screen since the update...

First BioWare Post First BioWare Post

RandolphWaite's Avatar

10.02.2013 , 09:30 PM | #1
I've just tried launching the game after the most recent update, and all I'm getting is a black screen. The cursor shows up as normal, and the menu music and sound effects start to play. I've also discovered (from the the sound effect as the mouse passes over the buttons) that the menu is fully loaded up and working, and, after clicking around in the right part of the screen for a bit, I managed to log one of my characters in and, judging by the noise of footsteps, walk around a bit. The screen remained totally black with nothing showing up apart from the cursor all this time.

I've checked other advice threads on black screen issues, and I've tried every single piece of advice given, including updating my graphics card drivers to the latest version available. Nothing has worked. Does anyone have any ideas on how to fix this?

Beruthien's Avatar

10.02.2013 , 09:36 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings RandolphWaite,

Have you tried placing the game into windowed mode by hitting Alt+Enter?

If you have then please come back to us with your DxDiag and the content of you client_settings file. You can find the client_settings.ini file in he following location:
Thank you!
Beruthien| BioWare Customer Service – Forum Support

RandolphWaite's Avatar

10.03.2013 , 01:17 AM | #3
I tried the windowed mode thing, I get exactly the same thing (black screen but everything else apparently working), just in a window.

Here's the DxDiag:


And here's the client settings file:


OwenBrooks's Avatar

10.03.2013 , 01:26 AM | #4
I am presuming that you are using bootcamp on the mac and they can use any standard drivers ?
my limit of knowledge on macs is they exist
If so use this tool to update the video driver - , the driver you have is from 2011 and is likely related to the black screen.

RandolphWaite's Avatar

10.03.2013 , 02:51 AM | #5
That's really strange, I was sure my graphics card's drivers were up to date - I actually updated them recently. Or is this a different set of drivers that are out of date?

Beesodd's Avatar

10.03.2013 , 02:55 AM | #6 Click here to go to the next staff post in this thread. Next  
Hi RandolphWaite,

Thre Dxdiag is showing 2011 drivers for your graphics card.

Driver Attributes: Final Retail
Driver Date/Size: 7/28/2011 22:39:14, 852992 bytes

It is odd alright, if they have been updated recently. Perhaps something went wrong during that process?

Anyway, I take it that the black screen issue is resolved now?


Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

RandolphWaite's Avatar

10.03.2013 , 02:57 AM | #7
I've never had this problem before, so I don't see how the drivers can be out of date for it now when they weren't about a week ago when I last logged in.

RandolphWaite's Avatar

10.03.2013 , 02:58 AM | #8
No, it's not resolved. I'm still getting the black screen.

OwenBrooks's Avatar

10.03.2013 , 03:00 AM | #9
Quote: Originally Posted by RandolphWaite View Post
No, it's not resolved. I'm still getting the black screen.
Run a dxdiag and compare the driver date has it changed at all ?

OwenBrooks's Avatar

10.03.2013 , 03:05 AM | #10
Try this driver - you are using bootcamp yes ?