Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Space Mission Achievments not working correctly

STAR WARS: The Old Republic > English > Flashpoints, Operations, and Heroic Missions
Space Mission Achievments not working correctly

AzazaelLoki's Avatar

07.12.2013 , 07:37 AM | #61
I now have 100% space complete, now if I could just get the broken two missions out of my legacy tracker I would be set.
Aza'zael - 55 PT Tank | Kantjil - 55 Op Heals

JonathanCP's Avatar

08.07.2013 , 07:09 AM | #62
Still having "Saleucami" achievements stuck in my achievement tracker window... (achievement "completed" but tracker still shows incomplete criteria)

BW said this was fixed in 2.3

Definitely not the case
If your thread title is not a variation on "open letter... BIOWARE,... fail... NOW!", then you are a fanboy

Kuciwalker's Avatar

08.07.2013 , 08:50 AM | #63
Quote: Originally Posted by AzazaelLoki View Post
I now have 100% space complete, now if I could just get the broken two missions out of my legacy tracker I would be set.
Yep, same. It is getting really annoying.

Armani_B's Avatar

09.15.2013 , 06:09 PM | #64
UOTE=soneil;6134318]Just confirmed this one with the same result. Easily got the objective for turrets and fighters. Took out every fighter I saw and also stripped every frigate of targets. The command ship was the only thing that still had anything on it and even on that I took out most targets.[/QUOTE]

I can confirm this one as well. Just tried it again a couple days ago since it's the only Space Mission Achievement that I don't have and was unsuccessful in getting this one. Which is a shame. I hate looking at my Achievement list under the Space section and seeing that glaring 98% Imperial and 99% overall. So close and yet so far.

Nothing_Shines's Avatar

09.18.2013 , 06:36 PM | #65
I had 100% completion on Space Achievements before 2.3 and now I log back in after a break and they're back to 98% Imperial/95% Republic, 97% overall.

Eliminate Fighters from Saleucami Fleet Action for Imps is now blank again, along with Neutralize Heavy Fighters for Hydian Way Blockade and Neutralize Enemy Fleet for Javaal Fleet Action.

NEW & RETURNING PLAYERS CLICK THE REFERAL LINK FOR ONE FREE SERVER TRANSFER, A FREE 7 DAY SUB & USEFUL UNLOCK BUNDLES FOR ALL OF YOUR CHARACTERS! Jedi Covenant || The Gallowglass Legacy || Merc-60 | Sorc-60 | Jugg-60 | Sent-60 | Com-60 | Op-60 | Shad-60 | GS-60 | Mara-60 | Guard-60 | Sniper-60

Ksinn's Avatar

09.22.2013 , 09:31 AM | #66
For a few weeks i had them all completed. Now it's again broken:
100% General
98% Imperial (missing 0/1 Eliminate Fighters from Salucemi Fleet Action)
100% Republic

StefanInter's Avatar

09.22.2013 , 11:14 AM | #67
Jip those were broken by BW in a patch. But since its not cm stuff, no need to get it fixed asap.

jujuj's Avatar

03.22.2014 , 10:37 AM | #68
I know this is an old thread but it came up in my search for the "Skaross Fortification Mastery" achievement because I could not get "Destroy the Republic Command" to complete. The information in this thread wasn't helpful so I did the mission with one objective and that was to destroy the Republic command any way that I could. I was able to complete this achievement by:
#1: disable the shield generators on the frigates (once you kill one, you get a bonus to get the other 3)
#2: disable the command module on the large republic fleet (it's the largest republic ship that you will fly by, look on top and you'll see a "fin" type thing and you will need to use your torpedo on it, it's on the very top of the largest ship, i think it's called the capital ship bridge). Once I had accomplished these 2 tasks, I received the Mastery achievement.