Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Was there a patch today? Please tell me no....

STAR WARS: The Old Republic > English > General Discussion
Was there a patch today? Please tell me no....
First BioWare Post First BioWare Post

CommunityDroidEU's Avatar


CommunityDroidEU
07.25.2013 , 03:38 PM | #81 This is the last staff post in this thread.  

Hi all

Please take a few moments and look over some of these pro-tips when posting on the forum:
  • No insults, name calling, or personal attacks
  • Please stay on topic.
  • Please express your opinion and thoughts in a constructive, respectful manner.
  • If someone violates the Rules of Conduct, please flag it instead of replying to it.
  • Keep in mind that everyone has different viewpoints. Just because someone disagrees with you doesn't mean they're trolling. If you believe someone is trolling, please use the Flag function to report their post.
  • Please remember that discussion of specific moderator actions is not allowed on the forums.

Thanks!

Smuglebunny's Avatar


Smuglebunny
07.26.2013 , 11:44 AM | #82
Quote: Originally Posted by AlienEyeTX View Post
Intel/NVIDIA combo spells doom.
Im a computer tech with multiple certifications and my experience is that anything BESIDES an Intel/NVidia combo is trouble.

K_osss's Avatar


K_osss
07.26.2013 , 11:46 AM | #83
@Sandy,
Sorry for your SWTOR woes. I had some kind of issue where SWTOR wasn't playing nice with my machine back in early 2012. I actually RMA'd my video card and motherboard trying to fix it. In the end Bioware eventually patched out whatever the problem was. Not sure exactly, but man was it frustrating!

i7-950 (tried stock, mildly overclocked and heavily overclocked nothing helped)
EVGA 580
EVGA 4 way Classy
12 gb Patriot mem

It was weird, only game that gave me issues. Glad it's gone now.

foxmob's Avatar


foxmob
07.26.2013 , 11:07 PM | #84
Quote: Originally Posted by Smuglebunny View Post
Im a computer tech with multiple certifications and my experience is that anything BESIDES an Intel/NVidia combo is trouble.
not the latest ATI, but very "new" AMD system all around. zero problems with new patch.
meh
Quote: Originally Posted by Jadescythe View Post
TL;DR Bolster is meant to help entry level players, ranked PvP is not entry level PvP.

sandyrocks's Avatar


sandyrocks
07.31.2013 , 09:33 AM | #85
Quote: Originally Posted by K_osss View Post
@Sandy,
Sorry for your SWTOR woes. I had some kind of issue where SWTOR wasn't playing nice with my machine back in early 2012. I actually RMA'd my video card and motherboard trying to fix it. In the end Bioware eventually patched out whatever the problem was. Not sure exactly, but man was it frustrating!

i7-950 (tried stock, mildly overclocked and heavily overclocked nothing helped)
EVGA 580
EVGA 4 way Classy
12 gb Patriot mem

It was weird, only game that gave me issues. Glad it's gone now.
Thanks.

Still have this problem....just saying.