Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

"Unknown Crew Skill"

pelicanjdf's Avatar

12.21.2011 , 11:14 PM | #1
I am very annoyed by the crew skills right now. I just got off of Tython as my level 10 Jedi Sentinel and I went to go pick up a set of crew skills. I went and got Artifice, and archaeology. I was on my way to get Treasure Hunting and when i got there it said that i already had 3 crew skills, sure enough I checked and I had randomly gotten Underworld Trading, when I try to unlearn it says "Unknown Crew Skill".

Is anyone else having this problem? And if so, how did you fix it?

Zailou's Avatar

12.21.2011 , 11:18 PM | #2
Try to send an ingame ticket?

Faynan's Avatar

12.22.2011 , 12:23 AM | #3
I had the same error.

After I learned my first and second crew skill, a third one was "magically" learned as well. When trying to delete it I would get "Unknown crew skill" as a message.

Finally, I deleted the first two I had learned, and the third slot became unlearned as well, (So I had no crew skills.) Learning the skills again, (though in a different order of trainers), worked and I now have the three crew skills I was wanting.

I submitted a ticket, but no word back yet.

Garde_Manger_Guy's Avatar

12.22.2011 , 12:27 AM | #4
Same thing happened here.
What happened to me was the game treated the second trainer I talked to as the reward part of the "Get a crew skill then talk to the trainer to get a reward" quest. (From the box in the hallway at fleet for me)

However, It also treated it as accepting the crew skill of the trainer I had moved to after that. (I had moved to a different trainer instead of speaking to the one I had just gotten the skill from to get the reward).

But since the reward is for or from the previous trainer, the "new" skill is set to 0 and you can't talk to the guy to fill the slot afterwords as it has already been "accepted".

However clearing it was easy as I deleted all my crew skills and started over. When I deleted the skill I got the reward from, both that skill and the one that got set to 0 were both removed.

I didn't bug this but should. I recommend that you do the same.