Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Cant get the game to launch at all...keep getting an Application error? Help?

STAR WARS: The Old Republic > English > Customer Service
Cant get the game to launch at all...keep getting an Application error? Help?

Dgree's Avatar


Dgree
12.21.2011 , 04:44 PM | #1
I'm really beginning to feel cheated here. Ive done all of The Installing...all of The registering and subscribed and when I go to press play after all of the patching and sort I get an error that says "swtor.exe-Application Error. The Application failed to initialize properly (Oxc0150002). Click on OK to terminate the application." I have a physical copy with a registration code. And my PC should be able to run this game....I have an Intel pentium D(Dual Core at 2.80 ghz) and my video card is a Nvidia G-Force 8500 GT. So can you please help me get this game going......Thanks anyone

Infernal_Marquis's Avatar


Infernal_Marquis
12.21.2011 , 04:46 PM | #2
I had a friend getting a similar error last night. According to him, he was able to fix it by installing Quicktime and rebooting. I would also advise to make sure that all windows updates are current.

Dgree's Avatar


Dgree
12.21.2011 , 04:49 PM | #3
My PC is updated....I will download Quicktime and see what happens....thanks.

Latech's Avatar


Latech
12.21.2011 , 04:55 PM | #4
My computer is pretty much the same spec as your and I have also gotten the same error.

Dgree's Avatar


Dgree
12.21.2011 , 05:13 PM | #5
I just downloaded Quicktime 7 and rebooted and it started up fine. Thanks for the tip...hopefully this is a fix for everyone with this problem. Oh...how i remember the days when everything you needed was included on the game disk. leave it to EA.....