Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Major lag after 2.0.0b


willfarlow's Avatar


willfarlow
05.24.2013 , 08:24 AM | #61
Quote: Originally Posted by ahnog View Post
For the life of me, and maybe someone can explain it, I don't see how bioware is responsible for this problem. The pings/traces show the problem to be in the path, not on bioware's end.

I'm on the Shadow lands and haven't seen this issue. Guess I've been blessed or something since so many have problems with it.
I agree with Vyerix...while I realize that BioWare may not be "responsible", per se, for the severe lag issues that have cropped up in the last few days, it seems to be a pretty big issue with a lot of players, judging from the number of posts on this forum. Anything that affects the quality of the game is, essentially, something that BioWare needs to at least be aware of. For myself, the lag makes the game un-playable, and I'm hardly going to continue to subscribe to a game I can't play. I understand that BW may not be able to "fix" the issue, but it would be nice if they at least acknowledged it. Even a "there's nothing we can do" would be better than seeming to be ignored.

OwenBrooks's Avatar


OwenBrooks
05.24.2013 , 08:38 AM | #62
Normally the only possible thing that may help is a VPN like wtfast or battleping, if it helps they essentially redirect the packets out via a different path for you.

http://www.wowinterface.com/download...atencyFix.html this is worth a shot , if it doesn't help just remove the changes. but it may help to recover quicker