Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Really Awful Performance/FPS on Makeb

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Really Awful Performance/FPS on Makeb
 

Microsoftenator's Avatar


Microsoftenator
04.18.2013 , 06:11 AM | #31
Bumping because I have this exact issue.

My specs are mid-low-end (Core 2 Duo 6550 2.33GHz, 6GB RAM, 1GB Radeon 4890) but I get 30-50fps in most places (even on the fleet).

I get <25fps on makeb (excluding the vendor area) and <15fps in combat, no matter what my settings are. I can't believe that I can't get playable fps even at 720p and absolute lowest settings.

lokozar's Avatar


lokozar
04.18.2013 , 06:16 AM | #32
I have the same issues on Makeb. Sometimes it get's down to 10-15 FPS, depends on the region.

Other planets average: 30-60 FPS.
IRIS - Inter Rim Investigation Service
<<Imperiale RP-Gilde auf Vanjervalis Chain>>

spectreclees's Avatar


spectreclees
04.21.2013 , 03:07 AM | #33
Morbidsouls has a thread about improving performance here:

http://www.swtor.com/community/showt...=619492&page=2

Check it out.

Rogoo's Avatar


Rogoo
04.21.2013 , 06:08 PM | #34
Quote: Originally Posted by spectreclees View Post
Morbidsouls has a thread about improving performance here:

http://www.swtor.com/community/showt...=619492&page=2

Check it out.
It is quite useless because the fact is that my rig exceeds recommended settings BY FAR and I'm still CPU bound on a six core CPU. So it's not my CPU it is the game and Bioware's terrible engineers.
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.

spectreclees's Avatar


spectreclees
04.21.2013 , 06:10 PM | #35
Quote: Originally Posted by Rogoo View Post
It is quite useless because the fact is that my rig exceeds recommended settings BY FAR and I'm still CPU bound on a six core CPU. So it's not my CPU it is the game and Bioware's terrible engineers.
Oh, I'm not saying this will help people. It might help some (or put an illusion it is helping). I'm just posting to be helpful if I can.

I know this game is optimized awfully. Just a messenger.