Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

[Bug] The Shroud's Last Stand - last binocular quest

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
[Bug] The Shroud's Last Stand - last binocular quest
First BioWare Post First BioWare Post

Dantharghan's Avatar

04.17.2013 , 04:14 PM | #1
We tried this twice so far.
We complete the quest up until the point where you have to dispatch the 4 Shroud's Replicator Droids after clicking on the holo terminal.
Each killed droid turns one of the red dots next to the door green.
We kill all 4 replicator droids, the door turns "green" as well, all 4 dots around it are green.... and nothing happens. The door just won't open.
Scanned the whole room with binoculars, there is nothing there to click.

Looks like this might be buggy.
Please look into it.

Irtax's Avatar

04.17.2013 , 07:17 PM | #2
We had the same issue tonight as well. Reset phase, went back in and killed the droids. Same result. Door indicators all turn green but the door won't open.

Hockaday's Avatar

04.20.2013 , 10:26 PM | #3
Same just happened to me. Reset phase and Mission. Trying again now, hopeuflly it won't bug out again.
The Empire is not evil, and the Republic is not is all a matter of opinion.
Nerf Hungering! It's too OP.=Bartle Test Results:= CE VIP
{Reward-Driven 85%} {Exploratory -60%} {Physical 32%} {Thoughtful -26%} {Social -60%} {Competitive 100%}

OwenBrooks's Avatar

04.20.2013 , 10:30 PM | #4
Spoiler -

May help or not after re-reading the OP

ShezarX's Avatar

04.21.2013 , 01:24 PM | #5
Same Problem here. The weird part is, that the big droid behind the light bridge didnt activate.... that may be the cause...

qAsandra's Avatar

04.21.2013 , 03:13 PM | #6
Same issue here. One thing I noticed in the guide was that everyone has to click on the holoterminal. Only 2 people in our group had completed the quest up to that point, the other 2 were just there to help and never got an option to click on the holoterminal. Could this be the issue?

Kalten-Siduri's Avatar

05.08.2013 , 03:45 PM | #7
I wish I had seen this before I tried tonight - We got all the ay to the end and the door...even killed the replica enemy, but the door wont open!

I am livid about this....who makes a quest that takes ages and needs 4 people that have never done it in order to complete without telling anyone?


We need a fix for this NOW please!
Anyone for a Monkey?

Kespar's Avatar

05.08.2013 , 03:52 PM | #8
Had this same issue in a guild group made up of 4 of us who had each attempted the mission before without success.

This time the same thing happened.

The fix we found, was to all leave area, and drop group.

The person with the least progress thus far reset the phase, went in alone then re-invited us to the group.

When we got back in to the replicator droid room he initiated the fight, and we focused one droid at a time moving on to the next only when one was dead.

Worth noting that the people replicated were different this time.

Once we did this, the door was able to be opened and the mission could be completed.

Hope this helps!

AmberGreen's Avatar

05.08.2013 , 04:18 PM | #9 This is the last staff post in this thread.  
Hi there folks! We just added a couple of bugs about this mission to the Known Issues, and there's a workaround for the Replicator Droids:
  • The Shroud Revealed (Republic)/The Shroud's Last Stand (Imperial): If players are in a group, the mission step “Defeat the Shroud's Replicator Droids” may not progress if Replicator Droids are defeated by a group member who is not currently on this mission.
    Workaround: Players can reset the phase or mission, ensuring that the Replicator Droids are defeated only by group members who currently have the mission objective.

  • The Shroud Revealed (Republic)/The Shroud's Last Stand (Imperial): Players who are defeated during the final encounter of this mission may be resurrected at the wrong Medcenter in a location further away than intended.

Both of these are slated to be fixed with Game Update 2.1.1, and as always, if there are any changes, we'll let you know!
Amber Green | Live Services Specialist
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]

Darth_pingu's Avatar

05.17.2013 , 08:37 PM | #10
Patch 2.1.1 is live and the glitch still exists.

Can you please credit me the last 2 hours back.

K, Thanks.