Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Broken Blades AGAIN...really

STAR WARS: The Old Republic > English > General Discussion
Broken Blades AGAIN...really
First BioWare Post First BioWare Post

stobin's Avatar


stobin
03.05.2013 , 11:14 AM | #1
BW get it right just one time. Why is it every time you release a double bladed saber you have to patch it for the blade to work right in combat? both cartel ones and now the gree one, is it really that hard to check prior to releasing it. I know it does not effect how works but really once maybe twice ok but damn 3 times!

CrazyCanukk's Avatar


CrazyCanukk
03.05.2013 , 11:17 AM | #2
Can you share with the rest of the class what exactly is broken?

I mean I (we?) am trying to understand your compliant but your extremely short on details to understand what specifically is happening that needs to be fixed.

JenseitsvonBose's Avatar


JenseitsvonBose
03.05.2013 , 11:34 AM | #3
Quote: Originally Posted by CrazyCanukk View Post
Can you share with the rest of the class what exactly is broken?

I mean I (we?) am trying to understand your compliant but your extremely short on details to understand what specifically is happening that needs to be fixed.
The back-side blade disappears entirely, and the particle effects disappear from the visible (front-side) blade.

It looks like your sin/shadow is using any old single-bladed lightsaber.
Jenseitsvonbose | Gunsmoke | Mcroyal
Shortbus - Resident Tendon Blaster - "What's a CC?"

Jaing's Avatar


Jaing
03.05.2013 , 11:34 AM | #4
The problem with BOTH saberstaffs from the Cartel Packs was that during combat (or sometimes just while running around, the "back" blade would dissapear. This resulted in what appeared to be a regular saber, with a really long hilt, being wielded in a very odd way by Assassins and Shadows.

In short, one of the blades doesn't show up some/most of the time.
PAXIMPERIUS
Website | Recruitment Thread

aeterno's Avatar


aeterno
03.05.2013 , 12:13 PM | #5
Single blade sabers suffer from a simmilar problem, saber throws turn the blade back to the shorter, particle effect-less state.

Still looks boss at the start of the fight tho lol, I'm tweaking my pve rotation to eliminate saber throws ;p

jgoldsack's Avatar


jgoldsack
03.05.2013 , 12:50 PM | #6
I personally wish it was an option to use a saberstaff with a single blade for some attacks. I like the look of it.
On the Internet, you can be anything you want. It is strange so many people choose to be stupid.

http://www.swtor.com/r/ycmWN7 <-- link for some free stuff!

Rafaman's Avatar


Rafaman
03.05.2013 , 01:09 PM | #7
Quote: Originally Posted by jgoldsack View Post
I personally wish it was an option to use a saberstaff with a single blade for some attacks. I like the look of it.
Yea. It does look good from time to time. Especially the way it's held and carried. I'm ok with the bug ironically enough. I had someone ask me the other day if I was a Guardian. Err... no I'm not but thanks for asking. Lol!

AmberGreen's Avatar


AmberGreen
03.05.2013 , 01:30 PM | #8 This is the last staff post in this thread.  
Hi there! This is a bug that we're aware of, and it's currently on the Known Issues. While I'm unable to tell you exactly when we'll be fixing this, unfortunately I know it's not in 1.7.2. Please watch the forums, and I'll be sure to get you guys an update as soon as we know more. Thanks!
Amber Green | Live Services Specialist
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]

Alec_Fortescue's Avatar


Alec_Fortescue
03.05.2013 , 01:40 PM | #9
Honestly - i'd love to be able to toggle between one or both blades being lit up. Bioware, make a toggle for that pls!
Bioware, please let us know if we're ever going to see iconic Jedi robes in the game... Or why not?

http://www.swtor.com/r/FsJS44 - Accept my referral to express gratitude for my years-long fight for iconic Jedi attire in this "Star Wars" game. You'll get some goodies on top of it, too.

MoobooMagoo's Avatar


MoobooMagoo
03.05.2013 , 01:47 PM | #10
If I had to wager a guess I would say that this might be a result of the bug where it looks like your weapon is out even though it is actually put away. Some classes don't have a problem with this (like when using pistols) but as a commando I will sometimes fire out of the gun while it is still on my back or run with it in one hand or something.

Try hitting z. If it is the bug I'm thinking of then you should take your weapon out even though you are already holding it. If I'm right then this should fix the problem. You can't do this in battle, but I hardly ever run into this problem while in battle.
Explorer: 80% Achiever: 60% Killer: 47% Socializer: 13%

Daniel Erickson and the Amazing Technicolor Dream-Abs