Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Third time a cartel pack has been missing items!

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Third time a cartel pack has been missing items!

Somajunkie's Avatar

02.22.2013 , 09:23 AM | #1
I called tech support about this a few weeks ago - I buy a bunch of packs, and one of them has only three items. It took pulling teeth, insisting that I wasn't lying about it - and finally CS gave me some coins after a week. Great, no problem. But then it's happened again to me, twice in the last day! And the last pack I opened had only ONE item.

I understand that there are bugs...what I don't understand is having to argue with CS about a real money transaction not delivering as promised.

ChuppaChugga's Avatar

02.24.2013 , 11:24 AM | #2
Give you a dollar, take back .99

Same thing happened to me, only three items. What;s worse is, one of the items vanished after I unpacked and tried to use it! I got an Ubrikki Crimson Claw Speeder as one of the THREE items. I had the basic speeder already in my inventory and was pretty happy to have pulled this (even though I only got 3 items). I removed the 'starter' speeder from my quick bar and replaced it with the Ubrikki. When I tried to equip it, it went grey. I left clicked again and BAM! it vanished. Then I realized that my basic speeder was gone from my inventory too!

Now, I payed to be a subscriber, payed to add cartel coins and, not only did I not get what the Cartel Pack specified in number of items, but I'm minus two items now?! I'm trying to remain calm about this and have placed a ticket into customer service. Hopefully this doesn't happen to more people but, it's making me a little 'wallet shy' about purchasing any more Cartel Coins.

ChuppaChugga's Avatar

02.24.2013 , 12:55 PM | #3
Update: Magically, deliciously my items are back.

LVCommando's Avatar

03.20.2013 , 08:53 PM | #4
This also just recently happened to me. About 2 days ago I was opening packs from a 24x box of the new Enforcers Contraband Packs. I know this has happened to me before a few times opening packs but I never thought anything of it as I wasent fully thinking of what I was supposed to get in the Cartel Packs. Now however the wording on the newest packs is VERY clear. "This Pack Contains 6 Items" Ok so now I get it...the more expensive packs should ALWAYS contain 6 items, the only variable is the type/rarity of some of the items within a specific class.

Ok says I. I only got 3 items when I opened this pack. I submit a help request ticket stating exactly what happened, the actual 3 items I DID get in the pack, and ask to have the pack replaced or something similar so I can get a pack with the correct amount of items in it. I wait 3 days and finally someone responds with, in essence "sorry, I can't find this in your character logs, bummers for you, can't do anything, but PLEASE contact us again if you have any problems" REALLY?!?!?? It showed up VERY Clearly in my chat tab from "System feedback" in yellow that I had opened a cartel pack and it listed VERY clearly that I had only gotten the 3 items I talked about in the help request.

So what is the disconnect here? Is there some special command I need to issue to make SURE my player logs are saved correctly so they can find these problems and fix them? Should I be screenshoting these things so I can prove to customer service i'm not lying to them about this?

What exactly should I have done to get this resolved other than what I did?