Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Hotspot Shield failing at school


Qiol's Avatar

12.20.2011 , 09:11 PM | #1
I have a peculiar problem with my bootcamped windows 7 on my 15" macbook pro 2011. During school, I use a program called hotspot shield to get by blocked sites. On my mac portion of my laptop, I can use the shield to play SWTOR on parallels 7. For some reason, when i'm on my windows partition and I have the shield on, I can't logon to the game...I get "login service is currently unavailable. try again later." I can't even access the login page on my web browser; it shows as this site as untrustworthy because it doesn't have a valid certificate and then my school's generic message for blocked sites appear after I click proceed anyway. I can still access other blocked websites though, it's just SWTOR's where i can't access the login page on the site or logon via the SWTOR launcher. By the way, I tried logging on at home with the hotspot shield and it worked fine. I'm hoping someone can help me with this problem because it's very irritating!