Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game unplayable

First BioWare Post First BioWare Post

Hoodieblocks's Avatar


Hoodieblocks
02.10.2013 , 02:09 PM | #1
I like many others have been getting dc'd then sent to frozen loading screen. Forcing me to restart the game. VERY ANNOYING. I was doing a heroic and whats wierd is, when i logged back on the group I was playing with said My toon was just standing there and It seemed like I had never left the game. Which would explain why usually when soloing I login to my toons dead body. Fix this problem please?

thomasbaxter's Avatar


thomasbaxter
02.10.2013 , 03:32 PM | #2
I found this problem was caused by playing over my wifi connection. Apparently small packet loss drives the game nuts so I hooked my router up to my comp through ethernet cable which solved the prob

jediturbodude's Avatar


jediturbodude
02.10.2013 , 03:40 PM | #3
It can happen at random, there seems to be no real cause other than the awful programming. Happens at least a couple or more times per week but for some it's daily

Bayen's Avatar


Bayen
02.10.2013 , 05:12 PM | #4
im getting this too please fix this bioware ;/

Cerimon's Avatar


Cerimon
02.11.2013 , 07:06 AM | #5 This is the last staff post in this thread.  
Hi All,

Firstly, if you connect via Wi-Fi please instead connect your machine directly with a cable if possible.

We do have a connectivity troubleshooting page here: http://www.swtor.com/community/showthread.php?t=1476
It may be helpful to some users to go through that and perform any of the relevant steps.

Please note we are unable to support users with 3G internet connections or over-clocked systems.

Cerimon | BioWare Customer Service - Forum Support

Seancstew's Avatar


Seancstew
02.11.2013 , 07:10 AM | #6
I get this as well, and I am not connected over WiFi. Nor do I have a 3g connection. It happens randomly. Very annoying.