Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Super Lag! D:

JellyPatootie's Avatar


JellyPatootie
02.02.2013 , 08:38 AM | #1
I've been lagging for the passed 2hours. For a few seconds my connection is fine, then all of the sudden it just goes -x-! And I am totally pissed.

I already tried resetting my connection, restarted my comp, did the troubleshoot thingy. Still the same.
And I asked all the other players in general chat if they were having the same lag issue, they said their connection is fine.

-Confused. :/

Darthdaedric's Avatar


Darthdaedric
02.02.2013 , 09:20 AM | #2
Gen Chat will ALWAYS say they're fine.
If this is about the US servers, the BioWare basically doesn't think there is a problem and refuses to fix it. They're just going suggest you talk to your ISP, who will in turn tell you there is no problem on their end.

Rezanian's Avatar


Rezanian
02.02.2013 , 09:22 AM | #3
I can't even log in to one of my character's it's so laggy. Freezes on the screen that says which chapter my character is on

OwenBrooks's Avatar


OwenBrooks
02.02.2013 , 09:22 AM | #4
Have you tried logging into a different server region, if the red x's do not appear it isn't likely an issue at your end, there is a large number of people experiencing similar over the last few days, and it may not of been fixed fully yet.
Few days ago a point halfway on the net to the US servers appeared to be causing the issues for most and have heard nothing to say it has been fixed.

A possible reason why the ones on chat say they have no problems, is depending on your location your IP and path to the same server can be different to someone else.

So they can be correct that they have no issues but you can be having issues even though it is the same server.

Amazing the number of people that think there is their end and biowares end but fail to think there is the thing called the internet in the middle.