Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Still screwing the UI when I change instances on a Planet

STAR WARS: The Old Republic > English > Customer Service
Still screwing the UI when I change instances on a Planet
First BioWare Post First BioWare Post

JLazarillo's Avatar


JLazarillo
01.08.2013 , 05:00 PM | #1
This has been going on for a couple of months now. Every patch I look to see if it's fixed, and every one, it hasn't been. It's not even listed in the known issues, so it's hard to tell how aware you all even are about this. It's hard to imagine that you're not, but on the off chance that it's unnoticed: changing from one instance to another of a planet (or the fleet, or whatever), will randomly cause target nameplates, self and target casting bars, and companion/teammate health windows to either not display properly, or, more often, not display at all.

It's restrictive to team play; I find myself not able to join teams effectively because if I have to cross instances, my UI gets screwed up. It's frustrating when I solo because if I get stuck in a highly-populated instance, mission objectives can become impossible to find at times. The problem is fixed by logging, changing areas, or instancing again, but the first two provide no assurance that I'll end up back in the instance I want, and the latter point has a long cooldown.

My gameplay has been getting rather frustrated by this; it'd be nice to know that a solution is at least being looked into.

AlixMV's Avatar


AlixMV
01.08.2013 , 06:51 PM | #2
Just adding that this is a problem I've noticed for a few months as well, basically since the last round of server merges and having to deal with multi-instanced planets for the first time.

A CTRL-U / CTRL-U to reset the UI works partially, but it still does screwy things.

Like, last night, my health bar over my head was showing as partially depleted even though the health bar down at the bottom was showing as full. The health bars of my party members were showing as full on the side even though I could see from the bar over their heads that they were taking damage during a fight. (This is a huge problem if you're playing, say, a healer character).

Logging off and back on isn't really a good solution, because there's nothing to stop you from being put into the wrong instance on re-log and having to go through it all again.
~ Jedi Covenant ~
Sollyni ~ Diyanna ~ Annifryd
Ydris ~ Mai'ty'lee ~ Lor'rysi

JLazarillo's Avatar


JLazarillo
01.15.2013 , 08:22 PM | #3
Checked it with today's patch, and, shouldn't be surprised I guess, but...
STIIIIIIILLLLL BROOOOOOOOOOOOOOOOKENNNNN.
Heck, it's still not even acknowledged.

Come on, guys, it was nice to see color unification get fixed, but that at least had a workaround.

AelixVII's Avatar


AelixVII
02.02.2013 , 04:24 AM | #4
Quote: Originally Posted by AlixMV View Post
Like, last night, my health bar over my head was showing as partially depleted even though the health bar down at the bottom was showing as full. The health bars of my party members were showing as full on the side even though I could see from the bar over their heads that they were taking damage during a fight. (This is a huge problem if you're playing, say, a healer character).
This happens to me all the time, when I group up 90% of the time the players are on another instance so I have to move to do group activity. It's a real pain. Really hope this gets fixed soon...

OwenBrooks's Avatar


OwenBrooks
02.02.2013 , 04:28 AM | #5
You have tried running the repair on the launcher at login before you click play ? (lower left cog)

DocTwister's Avatar


DocTwister
02.21.2013 , 09:02 PM | #6
Quote: Originally Posted by OwenBrooks View Post
You have tried running the repair on the launcher at login before you click play ? (lower left cog)
Has nothing to do with why this is broken. This is one of the most annoying bugs in the entire game. Yes, it is a bug and yes, it needs to be fixed.

Refreshing the UI does not work. The only thing that works is logging out, and logging back in OR changing to a different server such as getting on your ship and then off again will fix it or logging into an instance. So whatever behind the scenes refresh is happening with those moves, they need to be applied to changing instances too.

RoseofChaos's Avatar


RoseofChaos
03.03.2013 , 06:51 AM | #7
Bump. Same here.

Nitblade's Avatar


Nitblade
03.03.2013 , 10:52 AM | #8
Same here and it's a PITA
Commando [Gunnery] 60 , Sage [Seer] 60, Gunslinger [Sharshooter] 59, Sentinel [Watchman] 57, Vanguard [Shield Specialist] 60
Juggernaut [Immortal] 55, Sorcerer [Lightning] 60, Powertech 53, Operative 49

Nitblade's Avatar


Nitblade
03.08.2013 , 11:44 AM | #9
*bump
Commando [Gunnery] 60 , Sage [Seer] 60, Gunslinger [Sharshooter] 59, Sentinel [Watchman] 57, Vanguard [Shield Specialist] 60
Juggernaut [Immortal] 55, Sorcerer [Lightning] 60, Powertech 53, Operative 49

Beesodd's Avatar


Beesodd
03.08.2013 , 12:03 PM | #10 This is the last staff post in this thread.  
Thanks for the reports guys, unfortunately I don't have a definite fix for this.

It's odd that the Ctrl U isn't working for you. Just as a thing to check, please try clearing the game's cache. It might not work, but can help in tracking down some of the odder issues. To do that, navigate to the main game folder, and then the swtor subfolder, and delete the DiskCacheArena file found there. This will be recreated when the game restarts, and then check if the problem re-occurs.

Thanks.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.