Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Fix the GCD waste for sentinels/marauders

STAR WARS: The Old Republic > English > Classes
Fix the GCD waste for sentinels/marauders

LordExozone's Avatar


LordExozone
01.27.2013 , 07:46 PM | #11
I too have this issue on all my characters. I believe it has to do with the game not being able to cope well with rapid keyboard input, as I mostly have this when clicking my mouse button that has a macro bound to it too fast, or when I'm pressing buttons significantly faster than the global cooldown.
Kote! Kandosii sa kar'ta, Vode an.
Mandalore a'den mhi, Vode an. Bal kote, darasuum kote,
Jorso'ran kando a tome. Sa kyr'am nau tracyn kad, Vode an.

dipstik's Avatar


dipstik
01.31.2013 , 03:42 PM | #12
what woudl be helpful are combat logs. i get this problem all the time. for my merc i always will press the button for my unload after tracer missle just in case i got the proc (i kind of drum my fingers from unload to tracer missile) and sometimes the game will take a gcd from me when i pree the unload button even though i didnt get the proc and not activate tracer missile.

Cleet_Xia's Avatar


Cleet_Xia
01.31.2013 , 04:35 PM | #13
This "bug" is seen on all classes. The issue is caused by conection lag. The animations may not play ~ but the ability effect are still applied. You can "stack" abilities during one of these lag periods, and they will all apply simultaneously, but only the last ability animation will be displayed.
~Master Telagtun Telag of Lord Calypho~

shyroman's Avatar


shyroman
02.02.2013 , 09:56 PM | #14
Quote: Originally Posted by Cleet_Xia View Post
This "bug" is seen on all classes. The issue is caused by conection lag. The animations may not play ~ but the ability effect are still applied. You can "stack" abilities during one of these lag periods, and they will all apply simultaneously, but only the last ability animation will be displayed.
The problem is that the animation does play, but the ability doesn't apply its affects

Rawrwafer's Avatar


Rawrwafer
02.03.2013 , 12:15 AM | #15
I've had this problem too, it always happens more often when my ping is higher than normal. Its something to do with the connection between you and the servers.