Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Can't get past Character Select!

STAR WARS: The Old Republic > English > Customer Service
Can't get past Character Select!
First BioWare Post First BioWare Post

jemalpriscus's Avatar


jemalpriscus
01.19.2012 , 06:05 PM | #1
I've checked a bunch of the other threads and none of them appear to be the same problem as mine. Before the patch I was playing fine, but since the patch went up, now I can't play the game anymore!

I can log in fine and get to the character select screen, but when i pick a character and hit play, it goes to the loading screen and then.. weird stuff starts happening. Sometimes half the loading screen goes black, sometimes the entire screen flashes back and forth between loading screen and black screen, sometimes my computer freezes.. Once i THOUGHT i got in but it just showed the in game of me standing on my ship for like 10 seconds before crashing to desktop.

I've tried several times with a couple different characters.

Here's my specs, and as far as I can tell I have all the proper up to date drivers.
Intel i5-2500k CPU @ 3.30 GHz (4 CPU's)
8192MB Ram
Win 7 64 bit.
Video card: Nvidia GeForce GTX 560
DirextX 11

Anybody else having similar problems?

Bronholz's Avatar


Bronholz
01.19.2012 , 07:33 PM | #2 This is the last staff post in this thread.  
Greetings jemalpriscus,

Can you please try running the Repair function on the launcher. To do this please open the launcher and then click on the Cog icon.

If you are running the game in full screen mode, could you also try putting it into Windowed by hitting Alt + Enter.

Thank you for your continuing patience in this matter.
Bronholz | BioWare Customer Service Forum Support

McBlunts's Avatar


McBlunts
02.11.2012 , 04:38 PM | #3
Did this work?? I'm having the exact same issue
"Even with sureness, there must be doubt."

―Qui-Gon Jinn

XBOXKINGZZ's Avatar


XBOXKINGZZ
01.24.2013 , 04:44 PM | #4
Im haves the same problem! i can select character or even make new but once it goes to that loading screen after it freezes! I played this fine on my older PC and then the cpu fan broke and i had to build a new PC and ever since i got my new PC i cant play! Im a subscriber and paid for some items and never got to use yet some one should figure out whats wrong!

The only thing i did different on my new PC is i got the DVD and installed game from disc instead of downloading!

My PC passes all test on http://www.systemrequirementslab.com/cyri for the game!

Latest drivers, up to date direct X all .net framework, done everything! I tried on both my copys of XP! I have dual boot 64bit and a 32bit verson! I been reading many others having this problem!

Intel(R) Core(TM) i3-3225 CPU @ 3.30GHz
You Have: 31.3 GB
You Have: Microsoft Windows XP Professional Service Pack 3 (build 2600)
You Have: Intel(R) HD Graphics Family
You Have
Pixel Shader version 5.0
Vertex Shader version 5.0
Dedicated Video RAM 256 MB

Whitering's Avatar


Whitering
01.24.2013 , 04:51 PM | #5
Just a note, I built the computer I presently use when I got invited to the beta of Swtor (or the beta weekend I should say). The game crashed frequently and it was my video card, not the game. I didn't know for sure because it wasn't an overheating issue, it was just a bad card.

Do some memory tests, ME used to crash on me all the time or I'd have a hard time installing a particular game and it was one bad stick of ram out of the 4 installed in my machine causing the problem.

And once, a long time ago, the PS (brand new) was the issue.

There are some stress tester programs online, you might try them out. I am not saying it's not Swtors problem, because this game isn't super well coded by any stretch, but you might try to eliminate your own machine, especially a new one as the source of the trouble while waiting for a good tech response.

XBOXKINGZZ's Avatar


XBOXKINGZZ
01.24.2013 , 05:15 PM | #6
Did some test and stress test all seems fine!
http://www.passmark.com/baselines/V8...?id=4050204451
was done on my 32bit version of xp!

I did the FixLauncher.exe, and deleted patcher.version and retailclient_swtor.version both! Still no hope!
I tryed in full screen with all setting set to lowest as possible and window mode all setting set to low!
Did this on both my 32 bit and 64 bit windows!

My question i wonder is how many people having this problem used the DVDs to intstall the game?

XBOXKINGZZ's Avatar


XBOXKINGZZ
01.25.2013 , 08:37 PM | #7
Found A Fix!!!!!! This worked for me anyways!

At the bottom of Graphics page is a hidden setting "Visible Character Limit" set this to Low as possible!

After all the fixes I Tried After do this one setting it made it so it didn't freeze after character selection screen!