Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Game randomly logs off and get stuck on loading screen

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Game randomly logs off and get stuck on loading screen

thebvp's Avatar

01.25.2013 , 12:20 AM | #41
I was just able to do a hard mode flashpoint with no issues. I'm pretty sure what I did above fixed it.

Frankieservello's Avatar

01.25.2013 , 10:10 AM | #42
I am having this issue too. It seems like the patch today didn't do anything to fix this problem.

VigDiath's Avatar

01.25.2013 , 11:26 AM | #43
Same thing just happened to me. Questing on Belsavis, two times in a row within a 30-45 minute span, I was logged off twice and on this most recent time crashed to desktop.

The first time it happened, my connection indicator on the game screen showed I had no connection to the internet. I alt+ tabbed to desktop and had a full connection. In fact, my cell phone was still connected. Since it wasn't signing me off all the way, I just closed down the launcher. To be safe and make sure it wasn't an issue with my connection, I powered down my PC and reset my modem. After logging in, I was able to quest for a good 10-15 minutes and it happened again. This time, I closed the game and opened the launcher and logged back in. Maybe 5-10 minutes later I crashed to desktop. This was about 4 minutes ago.

I was not having this problem until today. In fact, prior to the most recent updates I had never really experienced a crash to desktop however they have become more frequently and happen usually at the end of certain flashpoints.

Today's incident happened to me on my Level 42 Jedi Knight character Madmartygan.
Server: Jedi Covenant
Jedi Covenant (The Baltimore Legacy)
Laaron - 55 (Shadow Tank) Eulora - 55 (Sage Healer)
Madmartygan - 55 (Guardian DPS) Skylaadawn - 55 (Sab Smug)
Akon - 55 (Carnage Marauder) L'aron - 53 (Sorc Healer)

Kailuchad's Avatar

01.25.2013 , 03:40 PM | #44
been happening off and on to me all week.

DakotaDoc's Avatar

01.25.2013 , 04:03 PM | #45
This is awesome, yet another bug that bioware has introduced with a patch. Your patches are buggy and untested, or are we the testers. Then I demand payment for my time testing.

5 times already in 3 hours I have got stuck on this loading screen. This is fun.... NOT!

monsewer's Avatar

01.30.2013 , 02:20 PM | #46
I'm having the same problem. It's happened about eight times in the past hour. Can't play at all.

I tried flushing my DNS cache, doing a repair and removing the DiskCacheArena file, and still the issue persists.

Dr_Cthulhu's Avatar

01.30.2013 , 02:24 PM | #47
Been happening all day to me. Annoying. Also sometimes the chat wheel doesn't show up. Don't know if they are related problems but hopefully its fixed soon!

boomeleven's Avatar

01.30.2013 , 02:34 PM | #48
My game keeps crashing and then a loading screen appears and fills up about 1/16 of the way and freezes. I've restarted my PC about six times to ensure it wasn't me. I run the sickest PC components (solid state, top GPU, 3rd gen iCore 7, etc. ) so I know for sure its not that.

So basically I was deep in Hoath doing a mission quest with my Jedi Sage. The game froze, loading screen appears and then II alt-tab out, right click the game and close it, then load back in and I am dead. The game freezes within about 60 seconds of login after that. I wasn't sure if it was just Hoath, so I used an emergency fleet pass to return to the Republic Fleet and the issue continued.

What would be nice is if I didn't pay for the game, I wouldn't be able to complain. Unfortunately, I do pay to play, for now...

SWTOR is about to lose me for the second time if this doesn't get resolved soon.

Tehdame's Avatar

01.30.2013 , 02:52 PM | #49
Yay this worked!!!
for like 10 minutes, then I started getting latency/disco's agian. FML.

Quote: Originally Posted by thebvp View Post
i think i may have fixed the problem. Here's what i did:

1) flush your dns cache. From the desktop, hit the start menu icon, then type "run" in the search programs and files field, then type "cmd" at the next window and "ipconfig /flushdns" in the command prompt that pops up.

2) delete the swtor cache. If you installed at the default location, navigate to c: => program files (x86) => electronic arts => bioware => star wars - the old republic => swtor and delete "diskcachearena." this file is created every time you start swtor, so it's safe to delete.

3) run the repair tool. Log in with the launcher, hit the gear in the lower left corner before starting swtor and run the repair tool.

Honestly, i don't know which of these three (or maybe a combination?) did the trick, but i've been running around the gtc for fifteen minutes now without a hitch and the problem seems to be the worst around high traffic areas.

Edit: I'm running windows 7.

Talox's Avatar

01.30.2013 , 02:54 PM | #50
Having the same issue as everyone else, tried many of the fixes offered, but as of yet, none have seemed to work. I go to having 1 little red bar, then an X then loading screen that sticks there. Kinda sucks.
"I can feel your anger. It gives you focus, makes you stronger."