Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error 1003

First BioWare Post First BioWare Post

Solitaire_Tiani's Avatar

01.25.2013 , 06:30 AM | #1
Having tried all the different proceegures,
Run repair utility
Check Time zone
Run as Administrator
Run fixlauncher.exe
Forward ports
Update Network card drivers
Reset router
Reset Winsock
Flush DNS cache
Proxy Settings
Run Chkdsk
Run Memory Diagnostic
Run Memtest x86
Disable overclocking
Check RAM settings in BIOS
Power management
Background applications

and formatted my laptop i was ready to give up, i then tried connecting to my friends network and the game worked!!!

my advice to anyone who is having the 1003 problem to try conecting on a diffetrent network on their computer (if its possible) and see if they can get through the server screen. if this works its not swtor its your ISP and you may need to change ur hub or router. im currently waiting for mine to be replaced so this is just a guid line. both myself and my friend are with virgin media. for the time being im using their network. this is just and idea for you guys still having trouble.
Proud to have played the first Rogue Squadron

Beesodd's Avatar

01.25.2013 , 06:35 AM | #2 This is the last staff post in this thread.  
Thanks for the post, Solitaire_Tiani. I'm sorry to hear that you've had so much hassle with resolving this but hopefully this will be helpful for any players who encounter this (if the standard troubleshooting steps don't help them).

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Solitaire_Tiani's Avatar

01.25.2013 , 10:01 AM | #3
Had my Hub replaced and swtor now works - Happy days =] it was a programing fault on the Hub itself and reseting cannot fix this, hope this is helpful to everyone!
Proud to have played the first Rogue Squadron