Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

trouble with downloading

deathscytheblood's Avatar


deathscytheblood
01.24.2013 , 08:36 AM | #1
Hey I went to download the new patch yesterday and it went all the way to 82 percent and then just stopped I let it sit for about 5 hours and it still did nothing I clicked out of the launcher but it would not let me and the only way to do so was to contol alt delete and use the task manager to do so I tried re downloading the patch and it stopped at 82 percent again and the same thing happened as before so I uninstalled the whole thing and redownoaded the game but it stopped at 99 percent download why did this happen when it worked fine before plz help me

ELizamariska's Avatar


ELizamariska
01.24.2013 , 08:41 AM | #2
a qoute from my theard as having simalar issues im trying this at the moment so cant say if it works or not yet

Quote: Originally Posted by OwenBrooks View Post
boot up in safe mode with networking see if it does the same, (eliminates most things that can conflict)
delete the patch folders and retailclient_swtor.version before trying again
run fixlauncher.exe