Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

GTX 680 - Poor Performance, looking for tips.

STAR WARS: The Old Republic > English > Customer Service
GTX 680 - Poor Performance, looking for tips.

Tazak's Avatar


Tazak
01.18.2013 , 05:52 PM | #1
Of course my rig:

-- EVGA GTX 680 Superclocked
-- i7-950 @ 3.6GHz
-- Asus P6X58D-E Motherboard
-- Corsair 12GB DDR3 RAM @ 1600MHz
-- Installed and playing on a Samsung 256GB SSD

I have tried MANY things to make this game run better on my computer. In the open world, I get a constant nice 60 FPS with my GPU usage sitting around 60 (I have Ambient Occlusion and FXAA enabled through Nvidia Inspector just as an FYI), but the moment I enter combat, enter a Warzone, or are surrounded by a large group of people, my framerate drops to 20-30 FPS. Changing graphical settings does little to this framerate drop, but what remains consistent is my GPU sitting at around 20-30% during the drop and my CPU at 30-40% usage.

I've tried changing compatability modes, changing .ini files to adjust settings, running without vsync, running in fullscreen, using Inspector's AA rather than the in-games AA, changing hardrives that the game is installed on.

Any tips or suggestions at all are deeply appreciated, thanks!
*Pops Flare*
Koos - 50 Jedi Sentinel (Ajunta Pall RP-PVP [Server First 50])

#4863#

OwenBrooks's Avatar


OwenBrooks
01.18.2013 , 05:55 PM | #2
I gather you are noticing something in the gameplay to be concerned ? stuttering ?

I run a 670GTX on defaults and get max i think 110 fps in most places, sometimes it drops for a few seconds on loading etc but worst i have seen it ever drop too is about 50. (vsynch off)

Tazak's Avatar


Tazak
01.18.2013 , 06:35 PM | #3
Yeah, it revolves around combat and large player quantities. It's mostly the fact that the FPS doesn't change no matter what settings I'm at.
*Pops Flare*
Koos - 50 Jedi Sentinel (Ajunta Pall RP-PVP [Server First 50])

#4863#

OwenBrooks's Avatar


OwenBrooks
01.18.2013 , 06:47 PM | #4
What color is the fps display ? I had pulled a previous post on colors from CS but it may have been wrong, going to go look it up again.

Quote: Originally Posted by Cerimon View Post
Greetings All,

So the actual explanation of the FPS display colors:

Red = Rendering bound/Video Card
Green = Simulation bound/CPU
Yellow = Mix of both
Current FPS (Lowest FPS over the last 10 seconds or so)

Thank you for playing Star Wars: The Old Republic

OwenBrooks's Avatar


OwenBrooks
01.18.2013 , 07:00 PM | #5

Tazak's Avatar


Tazak
01.18.2013 , 07:11 PM | #6
Quote: Originally Posted by OwenBrooks View Post
What color is the fps display ? I had pulled a previous post on colors from CS but it may have been wrong, going to go look it up again.
The colors are flashing constantly and not expressing one consistently.
*Pops Flare*
Koos - 50 Jedi Sentinel (Ajunta Pall RP-PVP [Server First 50])

#4863#

OwenBrooks's Avatar


OwenBrooks
01.18.2013 , 07:24 PM | #7
Quote: Originally Posted by Tazak View Post
The colors are flashing constantly and not expressing one consistently.
Wow now that sounds unusual, Mine is always RED even at 110fps , means I hit my GPU limit

What happens if you disable Ambient Occlusions ?

OwenBrooks's Avatar


OwenBrooks
01.18.2013 , 08:00 PM | #8
Other things to test seperately if you are an OCer , try turning off these one at a time

CPU - Turn off Intel Hyperthreading , will run your cpu cooler thats for sure.

GPU - Right click on the desktop, select NVIDIA control panel, expand the 3d settings, select manage 3d settings.

In the right panel select the second tab "Program Settings", select swtor and if it's not there just click add and browse to the app's executable.

Then just turn off threaded optimization for that app, click apply, close nvidia control panel.

It will be interesting to see if either of these affects your fps.

Tazak's Avatar


Tazak
01.18.2013 , 08:01 PM | #9
I'll do a quick test to see if a color shows up with Occlusion disabled. I'm actually just defaulting my Inspector profile so the game is currently in default graphics mode.
*Pops Flare*
Koos - 50 Jedi Sentinel (Ajunta Pall RP-PVP [Server First 50])

#4863#

Tazak's Avatar


Tazak
01.18.2013 , 08:09 PM | #10
Now after disabling my Inspector profile, turning all options off to bare minimum in the game settings, I am achieving around 30 FPS in warzones during combat and now it sits a secure RED for the FPS meter.
*Pops Flare*
Koos - 50 Jedi Sentinel (Ajunta Pall RP-PVP [Server First 50])

#4863#