Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

No Program Associated to view Patch Notes

STAR WARS: The Old Republic > English > Customer Service
No Program Associated to view Patch Notes
First BioWare Post First BioWare Post

thewitchdoctor's Avatar


thewitchdoctor
01.18.2013 , 02:16 PM | #1
I am running Windows 8 Pro (64-bit) and Google Chrome is my default browser. (And set as such in my control panel).

However, when I click on the "Read Patch Notes on SWTOR.com" button on the SWTOR launcher, I get this error:

"This file does not have a program associated with it for performing this action. Please install a program, or, if one is already installed, create an association in the Default Programs control panel."

Help please?
Good. Bad. I'm the twi'lek with the saber.
DPS: Carnage Marauder - Gunslinger
Tanks: Guardian - Juggernaut - Powertech - Assassin

thewitchdoctor's Avatar


thewitchdoctor
01.18.2013 , 02:22 PM | #2
Just a follow-up: this isn't new. It has been like this since I first installed (from fresh, mind you) Windows 8.

Also, I do not get this error anywhere else.
Good. Bad. I'm the twi'lek with the saber.
DPS: Carnage Marauder - Gunslinger
Tanks: Guardian - Juggernaut - Powertech - Assassin

thewitchdoctor's Avatar


thewitchdoctor
01.18.2013 , 02:35 PM | #3
Repair didn't solve the issue.
Good. Bad. I'm the twi'lek with the saber.
DPS: Carnage Marauder - Gunslinger
Tanks: Guardian - Juggernaut - Powertech - Assassin

Bronholz's Avatar


Bronholz
01.18.2013 , 02:42 PM | #4 Click here to go to the next staff post in this thread. Next  
Greetings thewitchdoctor,

Thanks for contacting us.

Something you can try is re-downloading the latest version of the launcher from here.

Thanks for your patience.
Bronholz | BioWare Customer Service – Forum Support

TheSkate's Avatar


TheSkate
01.18.2013 , 04:23 PM | #5
Quote: Originally Posted by thewitchdoctor View Post
Just a follow-up: this isn't new. It has been like this since I first installed (from fresh, mind you) Windows 8.

Also, I do not get this error anywhere else.
Sounds like a Windows error, not a SWTOR error.
It would appear that you do not have a program associated with the file type (https://) pointed to by the shortcut provided on the launcher.
Not sure how to make sure chrome is set up for secure internet since I don't use it. However, make sure that chrome has https:// files associated with it or enabled.
If that doesn't work try reinstalling chrome.
If that doesn't work try installing Firefox, setting Firefox as the default web browser, and seeing if it will work then.
"Blah blah blah, yackity smackity, and a nice cold glass of orange juice"
Hugh Tasmanian Devil

thewitchdoctor's Avatar


thewitchdoctor
01.18.2013 , 05:22 PM | #6
Thanks both of you.

I'll try both when I finish playing.
Good. Bad. I'm the twi'lek with the saber.
DPS: Carnage Marauder - Gunslinger
Tanks: Guardian - Juggernaut - Powertech - Assassin

thewitchdoctor's Avatar


thewitchdoctor
01.19.2013 , 10:58 PM | #7
It is Chrome.

I made IE my default browser and voilà, it worked. If someone else ever Googles for this problem; there you go!

I haven't bothered to try reinstalling Chrome yet. (Too busy playing).

Thanks again.
Good. Bad. I'm the twi'lek with the saber.
DPS: Carnage Marauder - Gunslinger
Tanks: Guardian - Juggernaut - Powertech - Assassin

TheSkate's Avatar


TheSkate
01.20.2013 , 07:38 AM | #8
Quote: Originally Posted by thewitchdoctor View Post
It is Chrome.

I made IE my default browser and voilà, it worked. If someone else ever Googles for this problem; there you go!

I haven't bothered to try reinstalling Chrome yet. (Too busy playing).

Thanks again.
Glad I could help. Enjoy the game.
"Blah blah blah, yackity smackity, and a nice cold glass of orange juice"
Hugh Tasmanian Devil

JuryDuty's Avatar


JuryDuty
03.01.2013 , 11:32 AM | #9
Hmm...I'm getting the same error, but don't want to make IE my default browser. Is there a way to fix this in default filetypes?
--JuryDuty

Beesodd's Avatar


Beesodd
03.01.2013 , 11:35 AM | #10 This is the last staff post in this thread.  
Hi JuryDuty,

I think setting the default in IE is the only way to do this, as it would be the default that the launcher is set to.

If you want to save it to somewhere handy for the future, the link for patchnotes is www.swtor.com/patchnotes

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.