Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Legacy Race Unlock Problem

DaForcee's Avatar


DaForcee
01.12.2013 , 07:34 AM | #1
I just purchased the race unlock for Milialan for 435k on the GTN. The character I bought it on is a level 43 Jedi Guardian with a Legacy level of 11. When I tried to activate the icon, it said in red writing," You've already unlocked this on this character". I thought that because he was on the Republic already and, knowing that all Republic characters have the race unlocked, that I should try it on my level 48 Marauder. When I mailed it to him and used it, the same message came up. I have no idea what to do

P.S. The icon has a quantity on it of 1, doesn't have the Cartel symbol, and is dimmed out. Hope this helps.

JediMB's Avatar


JediMB
01.12.2013 , 08:10 AM | #2
It seems, basically, that Unlock items purchased from the Cartel Market before this past Tuesday's update have become completely unusable. I have the same problem with an [Unlock: Cargo Bay (Account)] item, and I've had a support ticket about it open for the last three days without any sort of response.

So as if it wasn't embarrassing enough that they managed to break all already purchased Unlock items, they also don't have the customer service staff necessary to actually serve their customers in anything resembling a timely manner.
The Morrowbringer Legacy The Red Eclipse (PvE) [EU]
Deep into that darkness peering, you reach out your hand and grasp what you are searching for.
Now ring the bells that sweep away the darkness; the bells that beckon tomorrow's dawn.

Zomgmeister's Avatar


Zomgmeister
01.12.2013 , 03:44 PM | #3
Just posting here to say that I have exact same problem, only with a different race, and I also tried to send the unlock to other character to no avail. Also got broken unlock 10 inventory slots now.

If this thing is not a material for a QUICK fix, then I don't know what is.

Viralset's Avatar


Viralset
01.12.2013 , 04:03 PM | #4
I had the same problem with the Rattataki race. posted and got this reply: http://www.swtor.com/community/showthread.php?t=584998

Viralset's Avatar


Viralset
01.12.2013 , 05:47 PM | #5
Mine just got working now.

Zomgmeister's Avatar


Zomgmeister
01.13.2013 , 07:53 AM | #6
You're lucky. Mine doesn't work as of 30 min ago.

And still (about midnight UTC in between of 13 and 14 January) doesn't work. Just checked GTN: no blacked out items there, but no Sith Pureblood unlock available at the moment. And anyway, it's completely idiotic to buy another one, because one I have now should work.