Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Quickbar key 1 still assigned to right click?

STAR WARS: The Old Republic > English > Customer Service
Quickbar key 1 still assigned to right click?
First BioWare Post First BioWare Post

Antitso's Avatar


Antitso
01.03.2013 , 07:43 AM | #1
So I've come back, it's been a while, re-subscribed etc. Never got to play much of the game before as it didn't work well on my previous system.

2 tickets I had submitted previously have still not been resolved and have both been closed lol.. and I'm surprised no one else has complained about this.

I like to customize my keys quite a bit, and one of them is getting rid of auto fire from your main quick bar, it's not needed there as it has no cool down or cost and therefore you don't need to keep an eye on it.

Unfortunately when I move my hammer shot (trooper) to another quick bar and replace key 1 with another ability (I currently have Concussion Charge there) it will cast that other ability every time I right click an enemy. There is literally no option to unbind this function. It is somehow embedded into the programming. Now you might just say don't right click someone, (actually if you're thinking that I hate you) but it becomes habit from other games. Either way this shouldn't be the case.

Either Swtor intended for right click to always be semi-automatic fire (which is fair enough, but I still don't think you should force someone to use this binding)

Or its simply a bug and the embedded key binding is not intended.


So fix please... I don't want to keep casting Concussion Charge every time I accidentally right click an enemy... (honestly I still can't believe this issue hasn't been resolved already, I feel like I've over-looked something as I can't actually believe players put up with this!)

Antitso's Avatar


Antitso
01.03.2013 , 12:35 PM | #2
bump, down to page 3 already. THIS IS MAJOR STUFF GUYS.

Beesodd's Avatar


Beesodd
01.03.2013 , 01:13 PM | #3 Click here to go to the next staff post in this thread. Next  
Hi Antitso,

RMB being bound to slot 1 is intended, and is hard-coded into the game. You may wish to give your feedback on the Suggestion Box subforum. You're certainly not the first person to mention making RMB rebindable.

I hope this helps.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

xxpcwizardxx's Avatar


xxpcwizardxx
01.03.2013 , 01:23 PM | #4
go to preferences>Key Bind>Quick-bars and check if slot 1 is bind to right click, also try reset page

last resort:

also have you tried clearing the games settings cache by going to
C:\Users\You\AppData\Local\SWTOR\swtor\settings

and deleting all Configuration settings files and open the game again so it will create a fresh one
May The Force Be With You.

Beesodd's Avatar


Beesodd
01.03.2013 , 01:29 PM | #5 This is the last staff post in this thread.  
Hi xxpcwizardxx,

Unfortunately, the RMB = Slot1 bind can't be removed or changed.

Also, the keybindings are stored server-side, so changing the local settings files won't have any effect.

Thanks for the help, but there's no workaround in this case.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

xxpcwizardxx's Avatar


xxpcwizardxx
01.03.2013 , 01:31 PM | #6
couldn't the in game tech put it back to key 1 on the KB
May The Force Be With You.

Antitso's Avatar


Antitso
01.03.2013 , 07:24 PM | #7
I've just suffered a brain meltdown! One is forcing me to put an auto attack on my quick bar, how very dare you!

I will persist on my conquest for justice (in the sub forums) thank you for your response.

ervandeleo's Avatar


ervandeleo
06.28.2013 , 10:21 AM | #8
this happen to me too!!...what should i do now???delete my character??or what?can i fix this?please help me...