Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

SWTOR on Linux (Mint 14 Nadia 64 bit)

STAR WARS: The Old Republic > English > General Discussion
SWTOR on Linux (Mint 14 Nadia 64 bit)

TangledDruid's Avatar


TangledDruid
12.30.2012 , 05:13 PM | #1
I ran out of room on my hard drive a few months ago and had to delete my windows partion. I finally found some time to see if I could play SWTOR again.

I still have the map issue; basically, if you put the mouse over a map dot that displays an area (Such as the corellia daily to loot an anti rad injector) the client will crash. It will also crash if you mouse over the quest name in the mission tracker. I could however, click on the item icon in the mission tracker and use the anti rad injector. (Being careful not to touch the quest name)
( http://bugs.winehq.org/show_bug.cgi?id=32092 )

On 64bit nadia, this is what you need to do:

Summary:
============================================
Run wine as a 32bit chroot
Apply the KUSER_SHARED_DATA patch ( http://bugs.winehq.org/show_bug.cgi?id=29168 )
Start SWTOR from a script so that some evironment variables get set, and the window size gets set so the launcher is useable
Install d3dx9, vcrun2008, and gecko to your wine prefix

Details:
============================================

Set up 32 bit chroot:
============================================
Based on http://wiki.winehq.org/WineOn64bit

$ sudo apt-get install dchroot debootstrap
$ sudo mkdir /var/chroot

Add the following to /etc/schroot/schroot.conf, replacing your username accordingly:

[quantal]
description=Ubuntu Quantal
directory=/var/chroot
users=username
groups=sbuild
root-groups=root

Create the chroot:
$ sudo debootstrap --variant=buildd --arch i386 quantal /var/chroot/ http://ubuntu.cs.utah.edu/ubuntu/

Make sure you have the source repositories in your software sources
*Note* Just selecting "Sources" in the software manager only added Mint sources. I had to add the src repo manually to /etc/apt/sources.list

Copy this line:
deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse

Paste it right below and add -src like this:

deb-src http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse

Update:

$ sudo apt-get update

Copy software sources to the chroot:
$ sudo cp /etc/apt/sources.list /var/chroot/etc/apt/

Enter the chroot:

$ sudo chroot /var/chroot

Once inside the chroot, install the build dependencies:

# apt-get update
# apt-get build-dep wine

Download Wine 1.5.20:

# wget http://prdownloads.sourceforge.net/w...1.5.20.tar.bz2

Extract Wine to /var/chroot/wine

# tar -xvf wine-1.5.20.tar.bz2
# mv wine-1.5.20 wine
# cd wine

Download KUSER_SHARED_DATA_18 patch ( http://bugs.winehq.org/show_bug.cgi?id=29168 )

# wget -O KUSER_SHARED_DATA http://bugs.winehq.org/attachment.cgi?id=42706

Apply patch

# cat KUSER_SHARED_DATA | patch -p1

Build Wine

# ./configure
# make

Exit the chroot

# exit

Add wine 1.5 to main system (so you can invoke 32bit wine from the regular system)
============================================

$ sudo add-apt-repository ppa:ubuntu-wine/ppa
$ sudo apt-get update
$ sudo apt-get install wine1.5

Install Winetricks
$ sudo apt-get install winetricks

Setup Your wine prefix
============================================
Create a folder to hold Wine prefixes (or bottles) ( More about prefixes - http://wiki.winehq.org/FAQ#wineprefix )
$ mkidr ~/WineBottles

All of the next commands start with WINEPREFIX=$HOME/WineBottles/swtor
This makes all changes affect only the swtor wine prefix, and not mess up any other prefixes you may have.

You need to Create your prefix directory as a 32 bit, so start wine once by opening notepad
This should create your prefix and set it up.
If you run just 'wine' and not '/var/chroot/wine/wine', and the bottle/prefix does not exist, it will create a 64 bit bottle/prefix. SWTOR needs a 32bit bottle/prefix.

$ WINEPREFIX=$HOME/WineBottles/swtor /var/chroot/wine/wine notepad
You can just close notepad once it opens.

Now install corefonts, gecko, d3dx9, and vcrun2008

$ WINEPREFIX=$HOME/WineBottles/swtor winetricks corefonts tahoma
$ wget http://winezeug.googlecode.com/svn/t...tall-addons.sh
$ sh ./install-addons.sh
$ WINEPREFIX=$HOME/WineBottles/swtor winetricks d3dx9
$ WINEPREFIX=$HOME/WineBottles/swtor winetricks vcrun2008

Now set the OS type to Windows XP

$ WINEPREFIX=$HOME/WineBottles/swtor winecfg

Set Up SWTOR
============================================
I copied my swtor directory from a backup of my windows partion and saved it to ~/WineBottles/swtor/drive_c/SWTOR

~/WineBottles/swtor/drive_c/SWTOR should be the directory that contains launcher.exe.

Create a launcher script ( I saved to ~/bin/swtor ) - make this executable
LD_LIBRARY_PATH and WINEARCH are needed to run 32 bit wine on x64

#!/bin/sh
export WINEPREFIX="$HOME/WineBottles/swtor"
export LD_LIBRARY_PATH="/usr/lib32/:/usr/lib/"
export WINEARCH=win32
/var/chroot/wine/wine explorer /desktop=SW:TOR,1000x614 "C:\SWTOR\launcher.exe"

I googled a SWTOR png image and created a menu item. You can also just open a terminal and run the script you made.

$ swtor
Or
$ /full/path/to/swtor

If you don't have a ~/bin directory.

My backup was at patch 1.4. This version of the launcher does not work with this setup.
If you have an older version of the launcher, you will just get a blue window and the launcher will not appear.

If this happens, browse to ~/WineBottles/swtor/drive_c/SWTOR, right click launcher.exe and choose "open with wine".
This will open it up with the system wine without any of our tricks, and it will update itself. Once the window goes away, you are on the verison that we need for the script, and it should work ok.

Once the launcher appears and you login, it should patch to the current version without issue when we use our script to launch.

Edited to correct folder path - Sorry

MysticMystro's Avatar


MysticMystro
01.02.2013 , 12:52 AM | #2
Nicely Done Tangledruid.

I am most of the way through this but ran into an error with:

wget http://winezeug.googlecode.com/svn/t...tall-addons.sh

it returns an error:

HTTP request sent, awaiting response... 404 Not Found
2013-01-02 01:46:43 ERROR 404: Not Found.

Is there another way to add this?
Thanks

Had to make sure I grabbed the full link from the address bar and it worked thanks again.

ckoneful's Avatar


ckoneful
01.02.2013 , 12:54 AM | #3
Quote: Originally Posted by MysticMystro View Post
Nicely Done Tangledruid.

I am most of the way through this but ran into an error with:

wget http://winezeug.googlecode.com/svn/t...tall-addons.sh

it returns an error:

HTTP request sent, awaiting response... 404 Not Found
2013-01-02 01:46:43 ERROR 404: Not Found.

Is there another way to add this?
Thanks
Your link is off, open the link(from the OP, not yours) in a new window and copy+Paste it from there not from this page. It's getting shortened on this current page.
73% Explorer60% Achiever53% Socializer13% Killer
60 Juggernaut 55 Operative 50 Mercenary 48 Sorceror
53 Guardian 50 Gunslinger 53 Vanguard 55 Shadow
100% of Class Stories completed

TangledDruid's Avatar


TangledDruid
01.02.2013 , 08:22 AM | #4
Yes, the forum shortened the url its winezeug.googlecode.com/svn/trunk/install-addons.sh

MysticMystro's Avatar


MysticMystro
01.03.2013 , 02:18 AM | #5
No Work for me.

Only differences for me were that I did the full swtor republic install in reg wine so i had a copy of it. I then moved the whole thing to the /Home/WineBottles/swtor/swtor directory.

I then created the script file with the:

#!/bin/sh
export WINEPREFIX="$HOME/WineBottles/swtor"
export LD_LIBRARY_PATH="/usr/lib32/:/usr/lib/"
export WINEARCH=win32
/var/chroot/wine/wine explorer /desktop=SW:TOR,1000x614 "C:\SWTOR\launcher.exe"

saved it as swtor.sh and made it executable.
I didn't have a bin folder so I just put the script in /Home/WineBottles/swtor

When I run it, it gives me a SW:TOR - Wine desktop and is just blue.

TangledDruid's Avatar


TangledDruid
01.03.2013 , 07:50 AM | #6
Make sure it is set to windows XP as the operating system:
$ WINEPREFIX=$HOME/WineBottles/swtor winecfg
First tab under "Applications"

Also, some people have had luck by copying a client_settings.ini from a windows install to /home/<username>/WineBottles/swtor/drive_c/users/<username>/Local Settings/Application Data/SWTOR/swtor/settings

Although when I got that blue window result, running the launcher with regular wine by right clicking on it got it to open and update itself.

The launcher will fail to run if it can't initialize direct3d either - what videocard and driver are you using?

MysticMystro's Avatar


MysticMystro
01.03.2013 , 11:56 PM | #7
Humm, I guess therein lies the problem.
/home/<username>/WineBottles/swtor/drive_c/users/<username>/Local Settings/Application Data/SWTOR/swtor/settings

This ends for me at:
/home/<username>/WineBottles/swtor/drive_c/users/<username>/Local Settings/Application Data

The /SWTOR/swtor/settings part of that line above does not exist for me.

My swtor install is located at: /home/<username>/WineBottles/swtor/swtor

Video Card 9800gtx ftw
Driver 304.43

MysticMystro's Avatar


MysticMystro
01.13.2013 , 02:58 AM | #8
Ok found my issue.

In the install directions it says put your swtor in this folder:
Quote:
~/WineBottles/swtor/SWTOR should be the directory that contains launcher.exe.
I had to put it in:
~/WineBottles/swtor/drive_c/SWTOR
Now it runs. but.. it only runs in windowed 1024x768

I have left the script size for launch at 1000x614 and changed the wincfg size for 1440x900 as per another forums suggestion but it doesnt change it. In fact in the game itself when I look under graphic settings, it only lists regular size resolutions, no wide screeen settings.

If anyone can point me in the right direction, I would appriciate it.

TangledDruid's Avatar


TangledDruid
01.13.2013 , 09:37 AM | #9
Oops - sorry about that. I edited the OP with the right paths.

I had that resolution issue in windows as well. I had to change to windowed mode, hit apply, then choose the correct resolution, hit apply, then go back to full screen. That has been like for me since 1.2.

MysticMystro's Avatar


MysticMystro
01.17.2013 , 06:56 AM | #10
I might not have given enough information.
I literally have no widescreen options in swtor other than the 1000x614 that the script sets for the login screen.
When I am in game and go to graphics and hit the resolution drop down box I only have these resolutions:
800x600
1024x768
1000x614 (a rez that has no earthly reason for being in the game other than being passed through from the script)
1152x864
1280x1024
1400x1050
1680x1050

I am completely missing these resolutions in game:
1280x960
1360x765
1440x900
1600x900

It's the same if I did the install in linux or if I just copied it over from windows (My windows install has all resolutions)
How did I lose them or not have them, and how do i get them back? Or am I out of luck and linux just won't play the game in widescreen?