Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

mouse buttons non responsive or cutting out.

STAR WARS: The Old Republic > English > Customer Service
mouse buttons non responsive or cutting out.

kidatwood's Avatar


kidatwood
12.06.2012 , 10:52 AM | #1
The way I play alot of times I will use the left and right mouse buttons to turn look around and move my character forward. Lately when I click the right mouse button to turn my character it does not engage to turn. I also noticed that if I push them together it doesn't want to move. when I use my mouse in other application it works fine. so has anyone else have this issue.

chimex's Avatar


chimex
12.06.2012 , 11:16 AM | #2
Nope, mine works fine. Was playing a little earlier today after patch
The Progenitor (RP): Shazmi:<Crimson Moon>

Vankris's Avatar


Vankris
12.06.2012 , 11:22 AM | #3
Quote: Originally Posted by kidatwood View Post
The way I play alot of times I will use the left and right mouse buttons to turn look around and move my character forward. Lately when I click the right mouse button to turn my character it does not engage to turn. I also noticed that if I push them together it doesn't want to move. when I use my mouse in other application it works fine. so has anyone else have this issue.
i did have the problem, i wanted to strafe, so i click right and , but instead, i turned right.
Sometimes, i even stop strafing and start turning instade then continue strafing al the while, i never release the RMB of the mouse.

I changed mouse, bough a 70 logitech mouse, problem just stopped. I don't know if the problem was the mouse or the driver or even the mouse pad, i just changed them all, install fresh driver and everything back to normal.
Shadow | Kinetic Combat

Jrpm's Avatar


Jrpm
12.06.2012 , 12:38 PM | #4
I have had similar problems. I have seen two patterns that can result in the issues:

1- USB wireless mouse seems to disconnect, ie, build won't move or fire. (Also, start to move and find myself 180 degrees around from the direction I wanted.)
cure: pull the wireless receiver from the 'puter, wait a couple of seconds and put it back. problem clears up.


2- Sometimes lag with the server stops me. Usually I end up being dropped and have to re-sign in. Other times, it clears up if I wait long enough. I think this is my ISP if not the SWTOR servers being overloaded, but I no longer have to get down and dirty on comm xacts. (Retired computer nerd.)

kidatwood's Avatar


kidatwood
12.06.2012 , 01:28 PM | #5
thanks ill try unplug and replug see if that helps