Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

(launcher) I've tried everything.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
(launcher) I've tried everything.

Sarcomot's Avatar

12.20.2011 , 09:57 AM | #1
As far as I know, at least, and my launcher still won't launch.

GPU drivers are up to date.
swtor.exe and launcher.exe are allowed in my anti-virus and firewall.
Port numbers are allowed on my modem.
DirectX is up to date.
Windows Updates are up to date.
I'm not on a LAN.
I am the admin on my comp, so everything is run as admin.

I've followed pretty much everything in the sticky, all to no avail. I've been able to open the launcher once, was able to watch the little intro movie thing, and then it crashed. Was able to get past clicking "Play" a couple of times, only to have it crash. Now launcher won't even launch. I haven't gotten any error notices.

Please help.

Sarcomot's Avatar

12.20.2011 , 10:02 AM | #2
Page 2 in less than 5 minutes? Bump for some info!

Sarcomot's Avatar

12.20.2011 , 10:24 AM | #3
Actually, here's my DxDiag in the event that anyone is bored.