Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

RE Schematics disappear after logout

STAR WARS: The Old Republic > English > Customer Service
RE Schematics disappear after logout
First BioWare Post First BioWare Post

JerumyRoph's Avatar


JerumyRoph
11.29.2012 , 01:26 PM | #1
The problem:
Learned schematics by reverse engineering disappear after logout.

There are many threads out there now of people with the same issue. Most have submitted a ticket and have received the response "Thank you for reporting a bug" but it doesn't appear to have made the known issues list. I for one, don't feel that this is an appropriate response as crafting is such an integral part of the game and it costs time and credits to gather, craft, and reverse engineer over and over to get the desired recipes. Perhaps some of the issues on the list are higher priority; however, that "The tooltip information for Ball Toss is incomplete" made the list, and this did not, seems a little strange.

There seems to be some consensus that the people experiencing this issue started with one crafting skill then switched to another. For example, I picked Armstech first then switched to Armormech. Now when I reverse engineer Armormech equipment and learn the next tier schematic from it, I can craft the learned schematic until I logout. After next log in the recipe is gone and I can no longer craft the higher tier item. It may be helpful to note that my other toons are not affected by this.

So in lieu of a solution from the powers that be, I have a couple of questions for people experiencing this issue:
a) Did you switch crafting skills and now experience this?
b) Have you tried switching back to the original skill and can now keep schematics learned by RE?
c) Do we have to start a new toon to get the crafting skill we want and be able to keep learned schematics or are all new toons since 1.5 affected by this?

I will try b) when I get a chance, but I would like to know if someone else tried this and it worked. Otherwise I guess I'll have to start a new toon and scrap this one...

Thanks.

Cabe_Drakora's Avatar


Cabe_Drakora
12.02.2012 , 12:35 AM | #2
I am experiencing the same issue, and i tried to switch back to the first trade i had picked and go from there but i still lose the schematics when i log out and log back in!! this needs to get fixed!

isigrl's Avatar


isigrl
12.02.2012 , 05:25 AM | #3
Quote: Originally Posted by JerumyRoph View Post
The problem:
There seems to be some consensus that the people experiencing this issue started with one crafting skill then switched to another. For example, I picked Armstech first then switched to Armormech. Now when I reverse engineer Armormech equipment and learn the next tier schematic from it, I can craft the learned schematic until I logout. After next log in the recipe is gone and I can no longer craft the higher tier item. It may be helpful to note that my other toons are not affected by this.

So in lieu of a solution from the powers that be, I have a couple of questions for people experiencing this issue:
a) Did you switch crafting skills and now experience this?
b) Have you tried switching back to the original skill and can now keep schematics learned by RE?
c) Do we have to start a new toon to get the crafting skill we want and be able to keep learned schematics or are all new toons since 1.5 affected by this?

Thanks.
a) Yes and no. It's a tricky bug.
On my jedi knight main that switched skills at the very beginning of the game, I can't keep the new schematics if they are learned by reverse engineering. However, I do keep those bought from the GTN (crafting schematics only, crafting missions bought from the GTN dissapear in the same manner).
On my alts that had never switched skills, I can keep all schematics learned from reverse engineering, no problem there. However, I cannot learn new crafting mission schematics bought from the GTN or aquired on other crafting missions (such as slilcing, treasure hunting, etc). This last bug is present on all my toons.
So it seems like the bug is affecting schematics for crafing items and crafting missions as well.

b) Yes, even after switching skills back, it still doesn't stick (new schematics disappear)

c) In my experience all toons, new and old are affected by this, since 1.5 [as described -> a)]

(Also - if I remember correctly, this is actually an old bug, that was already fixed at some point.)

JerumyRoph's Avatar


JerumyRoph
12.02.2012 , 07:22 PM | #4
Awesome info thanks! My hope is that if we can do some legwork on this, the devs may be able to use the information to make it easier to fix.

I haven't been on my affected toon since posting this but I will update when I do. I guess another question I would like to have answered is when changing back to the original crafting skill, did you switch back applicable gathering skills as well? Also, has anyone tried completely blowing away all gathering and crafting skills and start again with the original, and/or with a new skill set. For example, when I changed my crafting skill I only needed to change one gathering skill so I was able to keep the progress in the other one. Not sure why this would affect the crafting schematics but perhaps they are all tied together in code somehow.

Thanks again for the responses.

JerumyRoph's Avatar


JerumyRoph
12.03.2012 , 12:07 AM | #5
Success! In my case anyway... [Edit] Recinded... see below

First, tried switching back to original skill set: Armstech, Scavenging(didn't change), Slicing. Learned Armstech schematics from RE were retained after logout. Completely closed game and came back and they are still there.

Second, unlearned all three skills and retrained: Armormech, Scavenging(fresh start), Underworld Trading. Now the learned Armormech schematics are retained after logout. Again completely restarted game and they are still there. Another odd occurance after logout and login again, the previous purchased Armormech schematics returned (they were not available at first when I retrained armormech). However because they are higher level than my current armormech skill I can't craft them yet (the craft quantity shows a red number for the number of units I have matts available for crafting and craft attempt flashes "Crafting skill too low" - or similar - in red letters).

So, I'm not sure if there was some quiet server side fix that was done here, or if the sequence of the tests I did fixed it for me, but I now appear to be cured. There still needs to be a proper fix as there was a lot of time wasted getting my skills up to the level they were before blowing them away, but at least for some, the method I used may get them back in business. Please post back if you give it a try and have success.

Thanks

symke's Avatar


symke
12.03.2012 , 01:49 AM | #6
Quote: Originally Posted by JerumyRoph View Post
Success! In my case anyway...

First, tried switching back to original skill set: Armstech, Scavenging(didn't change), Slicing. Learned Armstech schematics from RE were retained after logout. Completely closed game and came back and they are still there.

Second, unlearned all three skills and retrained: Armormech, Scavenging(fresh start), Underworld Trading. Now the learned Armormech schematics are retained after logout. Again completely restarted game and they are still there. Another odd occurance after logout and login again, the previous purchased Armormech schematics returned (they were not available at first when I retrained armormech). However because they are higher level than my current armormech skill I can't craft them yet (the craft quantity shows a red number for the number of units I have matts available for crafting and craft attempt flashes "Crafting skill too low" - or similar - in red letters).

So, I'm not sure if there was some quiet server side fix that was done here, or if the sequence of the tests I did fixed it for me, but I now appear to be cured. There still needs to be a proper fix as there was a lot of time wasted getting my skills up to the level they were before blowing them away, but at least for some, the method I used may get them back in business. Please post back if you give it a try and have success.

Thanks
How many RE'ed schematics did you make before you logged out? I am really happy if you have actually managed to find a solution, but I am afraid if this is more a "bug of a bug" type of occurrence. You know, when you are able to RE and keep 2, 3 schematics in a row, but forth one will disappear again.
We have maintenance tomorrow, but his bug is still not in a "known issues" list, so it could mean they are not taking it seriously.
Nothing can surprise me any more when it comes to EA and incompetence of their service.

Cerimon's Avatar


Cerimon
12.03.2012 , 05:31 AM | #7 Click here to go to the next staff post in this thread. Next  
Greetings All,

Please see Joveths' most recent post regarding this issue here.

Thanks.

Cerimon | BioWare Customer Service - Forum Support

symke's Avatar


symke
12.03.2012 , 06:49 AM | #8
Quote: Originally Posted by Cerimon View Post
Greetings All,

Please see Joveths' most recent post regarding this issue here.

Thanks.
Greetings Cerimon,

How about making a query to the team that is fixing this (if anyone is) and tell us if we can expect this fix in tomorrow's update.
It's obvious you didn't even read OP's post or any other responses here, but that is to be expected from crappy CS your are a part of. Besides thread's title, this thread talks about a way to maybe circumvent this bug.
Please, please guys from CS .... put a little more effort into helping and not so much into only being seen in this forum. Right now it feels like we are getting help from those three monkeys (one cant' see, second can't talk and the last one can't hear).

Cerimon's Avatar


Cerimon
12.03.2012 , 08:39 AM | #9 This is the last staff post in this thread.  
Greetings symke,

I referred to Joveths' post because it confirms both that the issue is on our side and that it will up to us to provide the resolution.

We do not want to say that the fix will be available via tomorrows' maintenance because it is possible that the resolution could be pushed back to another maintenance period.

As always, we are aiming at fixing this as soon as possible.

Cerimon | BioWare Customer Service - Forum Support

JerumyRoph's Avatar


JerumyRoph
12.03.2012 , 12:12 PM | #10
Quote: Originally Posted by symke View Post
How many RE'ed schematics did you make before you logged out? I am really happy if you have actually managed to find a solution, but I am afraid if this is more a "bug of a bug" type of occurrence. You know, when you are able to RE and keep 2, 3 schematics in a row, but forth one will disappear again.
We have maintenance tomorrow, but his bug is still not in a "known issues" list, so it could mean they are not taking it seriously.
Nothing can surprise me any more when it comes to EA and incompetence of their service.
Thanks symke,

I had only learned one at the point that I posted success. I learned three more today, switched toons and came backto find the ones from today were gone... the first learned one remained though.

So no real success yet dammit!