Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Video graphics questions

Thoramyre's Avatar


Thoramyre
11.19.2012 , 05:40 PM | #1
First post ever on this forum.
I hope I'm posting this in the right place.
I am currently running a Radeon HD 5830 and quad core AMD 9500 2.20 ghz..
4 gigs of RAM, 64 bit OS, windows 7

Here's the problem, LOW FRAME RATES, lots of LAG!!
When I'm in an instanced area, no worries, when I'm in a group, I'm barely able to play.
I currently have all settings at low, which sucks as this rig has been able to play other graphic demanding games with no problem.
Needless so say this is VERY frustrating!
Any ideas, suggestions?

Thanks, for any constructive feedback, or advise.
Thor
There is no death, only the force.

jopi's Avatar


jopi
11.19.2012 , 05:59 PM | #2
Quote: Originally Posted by Thoramyre View Post
First post ever on this forum.
I hope I'm posting this in the right place.
I am currently running a Radeon HD 5830 and quad core AMD 9500 2.20 ghz..
4 gigs of RAM, 64 bit OS, windows 7

Here's the problem, LOW FRAME RATES, lots of LAG!!
When I'm in an instanced area, no worries, when I'm in a group, I'm barely able to play.
I currently have all settings at low, which sucks as this rig has been able to play other graphic demanding games with no problem.
Needless so say this is VERY frustrating!
Any ideas, suggestions?

Thanks, for any constructive feedback, or advise.
Thor
Join the long list Thor. Lots of us been complaining for several weeks about the same issue.
Maybe it will be fixed by Christmas , tho highly doubtful.

Thoramyre's Avatar


Thoramyre
11.19.2012 , 06:13 PM | #3
Thanks for the reply.
I've been thinking maybe the folks who write code do so with certain video cards in mind so to speak. I just wish I could play this game at its potential. I played WoW for almost 6 years, burned out and really enjoy this game except for the damn lousy frame rates, I know WoW isn't as demanding, but good GAWD!
I would have thought my rig could easily handle this game!! I mean I can play Crysis with all settings at high!!

If anyone has any feedback, I would greatly appreciate it. I really can't afford a new video card, besides this one should be able to do the damn job!

Thor
There is no death, only the force.

jopi's Avatar


jopi
11.19.2012 , 06:22 PM | #4
Its not your rig , I purposely bought a new vid card this pass spring to run on max settings. Ran beautiful , not even a slight hiccup or anything.

This changed overnight few weeks back , after some lovely patches, now I cant even get into the fleet , almost unplayable right now.

Thoramyre's Avatar


Thoramyre
11.19.2012 , 06:25 PM | #5
Also, on an added note.
It seems like this may be a common problem from what I've read on the forums.
So.... dev's, here's is a bit of advice.
If the game is lagging due to some code writing, you better get your crap together.
If the game doesn't deliver as expected, people WILL go elsewhere to get the gaming fix they want.
And you guys will be out of a job!!
The customer is your paycheck, without us....you gotta go get another job.
Do you really think in this economy thats a very good idea??
Just something to think about.

Thor
There is no death, only the force.

Thoramyre's Avatar


Thoramyre
11.19.2012 , 07:25 PM | #6
Okay, I have tried several fixes as listed in other threads....no luck.
For the love of GAWD, I really enjoy this game, but at these framerates....I'm very disappointed.

The hell with it, if the company doesn't patch, fix or do something soon...my first month subscription will be my last.

Sad to say, but this isn't right.

Thor
There is no death, only the force.