Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Terribly slow download speed, suggestions?

STAR WARS: The Old Republic > English > New Player Help
Terribly slow download speed, suggestions?

Drogynn's Avatar

07.02.2012 , 04:12 AM | #41
Ok, I have been searching the internet for the past 2 days on solutions and tried everything. Yes I read all posts here too and it doesn't get any higher than 10 kb/s!

So here is my situation. I bought a new PC. So I need to re-download swtor.
Before I used Windows XP. Now I got Windows 7. Tried everything, opening ports; disabling firewall entirely; Setting the P2P to "true". Pausing/Resuming. Uninstalling, Re-installing. What else is there to try? My connection is suppose to be great. And my download speed is good on anything else.

Getting desperate on this matter because it is a waste of my subscription if I cant even download the game

Sevris's Avatar

07.02.2012 , 05:48 PM | #42
Yea i'm now having the same issue, i live in county so i get slow speeds anyway, but i average around 200 kb/s to 400 kb/s. I've got two machines, one for me one for my wife, updated on her computer at 400 kb/s and on mine i'm at 10 kb/s and getting 'Network error while downloading patch. Retrying' at times. Just did a fix launcher which has been 'fixin' or upating as it says for the last 2 hours. I'm guessing something fluked on my machine since my wife's is working fine. P2P is true, and firewall is all good, anyone got any ideas?

Drogynn's Avatar

07.03.2012 , 06:38 PM | #43
I seem to have found what the solution was.. well kinda.
My machine has 32 GB of RAM and I had Windows 7 Home Edition installed.
Home Edition uses 16GB max. So I got the ultimate edition now and it downloads fast again.

I have no clue why but somehow it's related to what your system uses in RAM. I read a post on this topic of someone who uninstalled half of his RAM in order to get it downloaded and then re´nstalled it again after.

Fudgeismade's Avatar

07.04.2012 , 02:50 PM | #44
I have fast internet, but a wireless connection to my pc. Plays twitch games like bf3 fast, no lag, and downloads other stuff at 1 to 2 mb/s. I was getting 200-600 kbps on the client patcher until i stretched a cat5 from my router to the pc and it leapt straight to 2mbps.

mariusenciu's Avatar

11.19.2012 , 09:51 AM | #45

I have just purchased the game, and my download speed like everyone else is around 200kb/s, I have read the multiple forum post about this problem and applied all recommended solutions, it is obvious that the problem is server side. It is also obvious that no one is doing anything about it. This is unacceptable. I will loose days of subscription because of the download speed. I must literally sped days downloading the game.
The easiest solution would be if Bioware would please post a torrent download option on the site, however I doubt they will. So I am calling to the community, if someone can post a torrent with game ISO's if possible that would help many of us a lot. If they will not help us let us help ourselves.



Someone falling to the dark side.

Senatsu's Avatar

01.02.2013 , 08:10 PM | #46
I'm able to download at around 1 Mbps for approximately 15 minutes, then it slows down to 15-20Kbps. If I restart the launcher the download speed will go back up again, but continuing to shutting down and starting it up again is just stupid. 1 year after the game has been launched and this is the type of download speed I get? New low for BioWare and EA, terrible low.
I would agree to an Aion-type LFG system, but not WoW's LFD. We don't need Blizzard's failures in this game.

Sinapus's Avatar

01.02.2013 , 09:27 PM | #47
I'm not sure how long it took to install on my computer. I waited a few hours and finally stumbled off to sleep. When I awoke, it was finally finished and ready to run.
Maxim 37: There is no overkill, there is only "Open Fire" and "I Need to Reload."

Friend Referral Link.

nGAGE's Avatar

01.09.2013 , 05:45 AM | #48
I also suffer from this horrible download speed. I've got a 120Mbit connection and through steam I can download 20gb games within 30min. My SWTOR download however has now been running for 24hrs and I'm nowhere near done. When I right-click my SWTOR folder it's total-size is not even 13gb.

I'm pretty sure it's not just server related. My download starts with like 2000kbps and almost instantly drops down to 500kbps, then slowing down to anywhere between 50 and 200kbps. However, the 'total downloaded' part on the left doesn't increase at all during the first 15-30seconds. (probably verifying existing files?)
Also, when I quit the launcher, it doesn't even properly closes till after about 20 seconds it throws an exception. Also, while it's downloading, I constantly see a message pop up that a download may have stalled as there were no packets receive for 90 seconds. However, when this message appears, download speed indication tells me it's about 200kbps at all times.

I'm running Windows 8 Pro x64 (fresh install). (didn't have this issue about 6 months ago during my last fresh windows install (same OS, but release-preview)

If anybody has found the cause and/or a possible work-around, please let me know, coz I wanna play. Not watch the launcher do little to nothing to make it happen.

RenfieldXIII's Avatar

01.09.2013 , 06:18 PM | #49
I'm returning to the game (an original Beta tester here) and the d/l for the client is moving on at a whopping 0.02kb/s at slowest and 8kb/s at quickest. You've got nothing to complain about at those speeds, lol.

ssebarod's Avatar

04.18.2013 , 01:08 AM | #50
i got the same thing i left it for 24 hours my kb/p is unusually erratic

its soooooo weird