Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
× and all pages in French -- I'm in New Zealand

STAR WARS: The Old Republic > Français (French) > Service clients (Lecture seule) and all pages in French -- I'm in New Zealand
First BioWare Post First BioWare Post

Vapourise's Avatar

12.20.2011 , 06:01 AM | #1
Hi there,
Until today the SWTOR website was fine and in English.

Now all of a sudden, it's in French. My IP is similar to what it has always been (dynamic IP) and when you geolocate my IP it is traced back to Auckland, New Zealand.

What can I do?
Here's to World PvP

Laevena's Avatar

12.20.2011 , 06:28 AM | #2 This is the last staff post in this thread.  
Hi Vapourise,
you can change back to english when clicking on the the flag on the upper left hand corner of the page.

In the meantime we would recommend using 32-bit Internet Explorer 7+ or Firefox 3.5+ if not.

Please also clear the cookies from your browser cache, and then reload the webpage.

Below are instructions on how to do this using the recommended browsers:

Internet Explorer 8
  • Click “Safety” on the Command bar.
  • Select “Delete Browsing History”.
  • Select “Cookies”, and then click “delete”
Firefox 3.5
  • Click on “Tools”, and then “Options”
  • Select “Privacy”
  • In the Cookies panel, click on “Show Cookies”
  • Click on the “Remove All Cookies” button
Please note that the above steps apply to the browser versions listed. You can check your browser version by going to “Help” and then “About”. If your browser version is not listed above, please visit the following link for a guide on how to delete your cookies:

(Please note that we cannot accept responsibility for content on any external websites.)

If you have not tried already, please try using the most up to date version of Internet Explorer.

Laevena | BioWare Customer Service – Forum Support