Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

help.

First BioWare Post First BioWare Post

monstaLulz's Avatar


monstaLulz
11.10.2012 , 02:39 PM | #1
The SWTOR website for me is currently set on German. Every time I click English it goes write back to German. It is sooooo annoying. Could someone please help?

Thanks.

Asendari's Avatar


Asendari
11.10.2012 , 03:02 PM | #2
allow the changing of your cookies in your browser
Haus Kurita | Server Vanjervalis Chain

Mundako's Avatar


Mundako
11.10.2012 , 03:32 PM | #3 This is the last staff post in this thread.  
Hello monstaLulz,

Please delete your cookies and cache for swtor.com. You can do this through the browser's settings menu.

Please let me know if you require further assistance with this matter. Thanks.
Mundako | Bioware Customer Service - Forum Support