Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Graphics Tips - NVidia & ATI (Gain FPS and Quality)

STAR WARS: The Old Republic > English > Customer Service
Graphics Tips - NVidia & ATI (Gain FPS and Quality)

Obergoaschoitl's Avatar


Obergoaschoitl
10.04.2012 , 06:53 AM | #371
With my old Quad Q66 with 4gb ram i had 150-25 fps.
I tried all the tips available on the net - nothign helped.
Bought a neq CPU, Mainboard and RAM. i5-3570k with 16gb ram

i have 70-120 fps now, all fluid. NOW the game is REAL fun :-)

frankachino's Avatar


frankachino
10.17.2012 , 12:47 AM | #372
This worked wonders for me. Thank you!

pnrxtx's Avatar


pnrxtx
12.15.2012 , 05:54 AM | #373
game runs like crap for sure. xpsp3 trick didn't improve anything.
Not possible to run this game with shadows on high. FPS is everywhere from 25 to 100+ depending on zone.
This is on phenomIIx4 3800mhz gtx560ti 4gb ram. For sure above recommended setup.
With shadows on low its 60+ steady fps, but game looks like back to year 2004.
And don't say that i need a 200$ core i5, and same price gtx660/7870 to get to run this game with shadows on high with 60+ fps.

NemurY's Avatar


NemurY
12.18.2012 , 07:05 AM | #374
Quote: Originally Posted by pnrxtx View Post
game runs like crap for sure. xpsp3 trick didn't improve anything.
Not possible to run this game with shadows on high. FPS is everywhere from 25 to 100+ depending on zone.
This is on phenomIIx4 3800mhz gtx560ti 4gb ram. For sure above recommended setup.
With shadows on low its 60+ steady fps, but game looks like back to year 2004.
And don't say that i need a 200$ core i5, and same price gtx660/7870 to get to run this game with shadows on high with 60+ fps.
Do you want to hear something even more wrecked up? After one year...ONE YEAR....and this game's engine is the same...they did not even bother to make an announcement to actually let people know that there IS a problem indeed with it.
I have a Radeon 6970 x2gig of video ram memory. Amd phenom II x4 965 processor and wait for it...wait for it....12 gigs of RAM....guess what? It runs under 30 fps ON LOW SETTINGS in any warzone and in the republic fleet if i get 60 fps when i move my character ...its Christmas everyday. I can run BF3 on max settings with no fps issues at all, witcher 2, dead space 2 and i got a pretty fat folder with a bunch of other games that i have no issues at all. Bioware focused on story instead of actually optimizing this bloody game for some user videocards. So guys, you do not need to buy a better PC or a better component, admit the fact that some people got ripped off by buying this game.
"It is a place of great power, the dark side lives and breathes in the very core of this world."

AlrikFassbauer's Avatar


AlrikFassbauer
12.18.2012 , 07:14 AM | #375
Why are these tips merely for Win7 & Vista ?
Why not for Win xp ?

I'd like to learn how I can optimize my HD 7850 for Win XP.

NemurY's Avatar


NemurY
12.18.2012 , 08:10 AM | #376
Quote: Originally Posted by AlrikFassbauer View Post
Why are these tips merely for Win7 & Vista ?
Why not for Win xp ?

I'd like to learn how I can optimize my HD 7850 for Win XP.
These kind of tips came from people that are normal day users. Nothing is being given away from Bioware regarding the fps issues on different OS. They are keeping quiet because they either still have no idea what causes the engine problem or they do not know how to fix them. Why don't you try popping that question to them directly on customer support and see what tips they give you regarding windows xp and your GPU.
"It is a place of great power, the dark side lives and breathes in the very core of this world."

FyrosFulke's Avatar


FyrosFulke
11.29.2014 , 09:33 AM | #377
Is there an updated thread like this one for Windows 8/8.1 ? This is an amazing post, and helped me tons in the past. Looking for one just as intelligent for A windows 8 system, and specifically tips for AMD Radeon 7420G.

And by the way, all the posts from people who couldnt find "XP Service Pack 3" I had the same problem, the XP Service pack 3 doesnt exist -if you are using Vista-. But this windows 8 shows it for sure. VISTA does not have the option for service pack 3 (XP), so just pick service pack 2.


RANT, feel free to skip: I feel the need to express my annoyance for people that just assume it was operator error. Assuming people are stupid or unobservant when so many in this thread reported the same issue. Such comments are counter productive and unhelpful. Your initial assumption should be they are reporting something new. If they discover on their own they were the idiot, they will either go away or admit it and apologize. Dont be the dick side of the force eh?

valibad's Avatar


valibad
11.29.2014 , 05:40 PM | #378
Ok i have win 7, i7 3775k 16gb ram and r9 290
1080 rez everything on high 120 refresh rate
and my fps hit like 30 on oricon in action and
50 fps on fleet. Got heavy fps drops and it
dont matter so much if i drop settings or resolution.
Can it be becouse i dont have ssd?

I dont know but i think i should run better fps or wat?

four_fun's Avatar


four_fun
11.29.2014 , 06:28 PM | #379
No, it's not coz of lack of SSD, dude. The game engine is terribly SCREWED, something is broken here really hard. I got SSD, i7-3770k and GTX690 and have the same issue as described by posters above me, Also, I had similar problems on my other 3 machines, soo.... Fps drops dramatically in crowdy environments (WZ, raids) from 100 to even ~20. We need to give developers a red card, because they sit quiet and do nothing.

OwenBrooks's Avatar


OwenBrooks
11.29.2014 , 06:38 PM | #380
Read this - http://allisterb.blogspot.com.au/201...e-parking.html it sums up one possibility given this game is directx 9 and shovels texture data as well

Edit - One swtor thread - http://www.swtor.com/community/showthread.php?t=775851