Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Redeem Product Registration Code Issue

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Redeem Product Registration Code Issue
First BioWare Post First BioWare Post

--Mordecai--'s Avatar

12.13.2011 , 04:41 PM | #1
First and foremost, I apologize if this issue has been adressed elsewhere in the forums.

Weeks ago I pre-ordered and purchased the game online from origin. I got the confirmation email from Origin and the "Thanks for Pre-Ordering!" email from SWTOR. I redeemed my origin serial number (XXXX-XXXX-XXXX-XXXX-XXXX) where it said "Redeem Product Registration Code" on the My Account page weeks ago. Since then I've downloaded the Game Client and waited. Today, now that the forums are back up I checked the My Account page to find the following:

Get Ready To Play!
Five Security Questions-Checked
Contact Information Complete-Checked
Redeem a Product Registration Code-Unchecked
Subscribe (or redeem time code)-Unchecked

I clicked redeem code and tried to enter my XXXX-XXXX-XXXX-XXXX-XXXX style serial number again and got the error message that it had already been used. I also thought the game came with thirty free days so I should have a subscription. The highlighted red worries me. If anyone knows how this can be fixed or can give me a legitimate customer support number that does not have an asian robot who hangs up on me, I would greatly appreciate it.

-May The Force Be With You-

Tealik's Avatar

12.13.2011 , 04:45 PM | #2
"Originally Posted by Ahebish
Updated information from buddies of mine already in game

1. Pre-order codes from origin/amazon/etc are independent of the CHECK MARK of "Product registration Code" in your Accounts.

They do NOT effect your eligability to receive an invite into early access.

3 of my buddies are already in game, and have stated to this fact.

When the game is released... Dec 20th... THAT is when you need to enter your product registration codes on the TOR site.

To clarify: The product registration code is independent of your pre-order codes. You will be eligable to get early access with your pre-order codes, however on Dec 20th. You will receive a retail code from your respective digital download sites. Such as Origin or Amazon. This is the code that needs to be entered in the "Product Registration Code" The UNCHECKED that we all see."

Hope this helped.

emiljohkar's Avatar

12.13.2011 , 04:45 PM | #3
I have the same problem when i comes to Redeem Product Registration Code, i can see my code on my origin account but can not see it checked on my account. Also says its already in use.

As for your 30 free days mabe that will show up once the game goes live or the day u get access to beta? I have no idea just trying to throw some comfort your way.

Oh snap thanks alot Tealik clarifies alot of worries, hit reply before you had replied.

--Mordecai--'s Avatar

12.13.2011 , 04:49 PM | #4
-Thanks for posting that Tealik

-I also appreciate your follow up response Emiljohkar

Very helpful guys!

Wolframm's Avatar

12.13.2011 , 04:51 PM | #5
bumping so everyone sees this. was worried before i did.

mtamay's Avatar

12.20.2011 , 02:12 AM | #6
Hello, apology for my bad English.

I pre-ordered digital deluxe edition and got both keys. My early access key is working but i couldnt redeem my original game key.

When i clicked redeem code and tried to enter my game code system says "By redeeming this code, you are now registered for the following: STAR WARS(TM): The Old Republic(TM) Digital Deluxe Edition". Everything fine here by.

When I click to continue button it goes to code entry again and "Message not found" message appear on screen. It doesnt says this code is already used or anything else. Just turning back and not complating redemption.

E-mailed customer service but i got no responce yet, tryed to call and waited 30 minutes on phone but no ones answered. If anyone knows the solution please share it.

Thank you.

Laevena's Avatar

12.20.2011 , 02:23 AM | #7 This is the last staff post in this thread.  
Hello mtamay,

due to the hight traffic on it might be possible that you are experiencing trouble when redeeming your code.

We would advise you to try again.

In the meantime, please try the possible solutions below.

Try an alternative browser to the one you are currently using.
Please clear the cookies from your browser cache, and then reload the webpage. Below are instructions on how to do this using the recommended browsers:

Internet Explorer 8
  • Click “Safety” on the Command bar.
  • Select “Delete Browsing History”.
  • Select “Cookies”, and then click “delete”
Firefox 3.5
  • Click on “Tools”, and then “Options”
  • Select “Privacy”
  • In the Cookies panel, click on “Show Cookies”
  • Click on the “Remove All Cookies” button

Please note that the above steps apply to the browser versions listed. You can check your browser version by going to “Help” and then “About”. If your browser version is not listed above, please visit the following link for a guide on how to delete your cookies:

(Please note that we cannot accept responsibility for content on any external websites.)

If you have not tried already, please try using the most up to date version of Internet Explorer.

Do not hesitate to come back to us.
Laevena | BioWare Customer Service – Forum Support

Dracoform's Avatar

12.20.2011 , 03:59 AM | #8
This Solution is not working either..

Anything else we can do, or is it an in House problem?
Seeing we have the 20th and Im afraid I won't be able to play soon anymore due to a bug on the website.

The preorder code work fine so its not a general problem with the site, but with key verfication it seems.

I tried at several Times and Computers/Browsers at home and at work, but to no avail.

It just does't work :/

mtamay's Avatar

12.20.2011 , 04:56 AM | #9
I tried with different computers and browsers but nothing changed.