Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Still Stuttering after new patch 1.4.0b

STAR WARS: The Old Republic > English > Customer Service
Still Stuttering after new patch 1.4.0b
First BioWare Post First BioWare Post

Martin_Katarn's Avatar


Martin_Katarn
10.04.2012 , 11:42 PM | #51
I'm experiencing the same issue since 1.4 and It never happened before ( I play swtor since january)

Martin_Katarn's Avatar


Martin_Katarn
10.04.2012 , 11:51 PM | #52
I can play without the stuttering only in windowed mode with very high graphics and It works like before

CMoldas's Avatar


CMoldas
10.05.2012 , 12:55 AM | #53
None of the Dev posted fixes worked for me.

Running in windowed mode does nothing as well. Nameplates on or off does not help. Shadows on low or off does seem to improve it, but still can be a slide show in certain areas.

This is insane, just roll back the graphics to pre-1.4 please!

I have invested a lot into this gaming rig, and have been extremely pleased with how it runs SWTOR until 1.4.

Just very disappointing right now, and it seems it can be fixed anytime they want to. JUST GIVE ME MY OLD DAMN SHADOWS AND MY GAME BACK PLEASE!
-Vakkus
- Prophecy of the Five

Danylia's Avatar


Danylia
10.05.2012 , 03:33 AM | #54
Quote: Originally Posted by Cerimon View Post
Greetings All,

Please go through the following steps, testing the game performance after each. I will outline the steps in order of increasing difficulty/duration to complete.
  • Set shadows to low or off.
  • Turn nameplate scaling off.
  • Delete DiskCacheArena which is by default found at C:\Program Files (x86)\Electronic Arts\Bioware\Star Wars - The Old Republic\swtor
  • Delete client_settings which is by default found in the settings folder at C:\users\%USERNAME%\appdata\local\SWTOR\swtor\
    When you get in-game, set your graphics options to your preferences.
  • Perform a Clean boot.
  • Perform a clean install of latest non-beta video driver.
After 1.4, I could get rid of the stutter by turning the nameplate scaling off. After 1.4.0b, that no longer helped, however the stuttering was relatively minor. So I went through the abovementioned steps, and now the stuttering is 200%-300% worse, combined with small framerate loss, which in result makes the game unplayable.
My graphic card is ATI Radeon HD 5700.

warriorcat's Avatar


warriorcat
10.05.2012 , 03:50 AM | #55
Quote: Originally Posted by Danylia View Post
After 1.4, I could get rid of the stutter by turning the nameplate scaling off. After 1.4.0b, that no longer helped, however the stuttering was relatively minor. So I went through the abovementioned steps, and now the stuttering is 200%-300% worse, combined with small framerate loss, which in result makes the game unplayable.
My graphic card is ATI Radeon HD 5700.
doing these steps will not make it worse ... try the steps again launching the game after every time to see what makes the biggist affect
Aim the rockets at Tomb of Freedom Nadd!
Level 50's Darkri/Zeraya//Jess'e char slots used 11/12
level 55 Raffes

Danylia's Avatar


Danylia
10.05.2012 , 04:05 AM | #56
Quote: Originally Posted by warriorcat View Post
doing these steps will not make it worse ... try the steps again launching the game after every time to see what makes the biggist affect
I just reverted the drivers back to the older version, and the game went back to "minor inconvenience only". So it seems it were the newer drivers which made it worse for me - though it is of course possible that I did something wrong somewhere.

morfius's Avatar


morfius
10.05.2012 , 07:48 AM | #57
Done all things mentioned to remove stuttering, nothing helps.
After some plays with settings found that removing shadows (off), setting - Shader complexity on Very low remove stuttering with no difference is it full screen or not, is nameplates scaling turned on or off or any other settings in game or Nvidia control panel.
Low set on Shader complexity stutter lightly, High make game not playable.
Shadows I can live without ...

Edit:
What Google found ...

Let's be clear of what this new "very low shader" setting does:
1) add a new line in your settings.ini saying shaderset = 1
2) disables "reflections" layer from rendering (mostly found on metallic parts )
3) disables most of the "environment lightnings" (by example the fleet corridors lights disappear)
4) prevents any "shadow" to be created
5) I guess also that the shader computation is reduced in 16-bit depth because the basic colors are shifted
6) disables Bloom because of my guess 5) Bloom is still calculated in 32-bit depth and will be too strong on 16-bit textures.
7) Conversation Depth of Field turned Off


I think point 4 is the key here... shadows on nameplates.
Is there a settings (ini or control panel) to remove completely shadows without removing other points above?
"The Aing-Tii have a different view of the Force. Not in terms of Jedi or Dark Jedi—of black and white, as it were—but in a way I like to think of as a full-color rainbow."

warriorcat's Avatar


warriorcat
10.05.2012 , 08:31 AM | #58
Quote: Originally Posted by morfius View Post
Done all things mentioned to remove stuttering, nothing helps.
After some plays with settings found that removing shadows (off), setting - Shader complexity on Very low remove stuttering with no difference is it full screen or not, is nameplates scaling turned on or off or any other settings in game or Nvidia control panel.
Low set on Shader complexity stutter lightly, High make game not playable.
Shadows I can live without ...

Edit:
What Google found ...

Let's be clear of what this new "very low shader" setting does:
1) add a new line in your settings.ini saying shaderset = 1
2) disables "reflections" layer from rendering (mostly found on metallic parts )
3) disables most of the "environment lightnings" (by example the fleet corridors lights disappear)
4) prevents any "shadow" to be created
5) I guess also that the shader computation is reduced in 16-bit depth because the basic colors are shifted
6) disables Bloom because of my guess 5) Bloom is still calculated in 32-bit depth and will be too strong on 16-bit textures.
7) Conversation Depth of Field turned Off


I think point 4 is the key here... shadows on nameplates.
Is there a settings (ini or control panel) to remove completely shadows without removing other points above?
yes and that is bascily what they have asked ppl to do (and 7 is not needed you dont lag in chat scenes do you? but using the in game system ill edit in file location of the .ini

C:\Users\thomas\AppData\Local\SWTOR\swtor\settings (your will not have thomas (that is my user profile)) that file you edit is just more detailed than in game for example mine says and i dont lag if i start to i just switch shadows 100% off
Spoiler


it opens as a .txt not ini ( unless i am thinking of a differnt file )
Aim the rockets at Tomb of Freedom Nadd!
Level 50's Darkri/Zeraya//Jess'e char slots used 11/12
level 55 Raffes

morfius's Avatar


morfius
10.05.2012 , 08:35 AM | #59
In game system to do what exactly?
Nobody mentioned this setting and how it affect stuttering, find above was from months ago.

Edit, since 1.4 I have a white square at 1/4 of my screen on any logoff that disappear after 2 seconds.
Not a big deal but very strange.
"The Aing-Tii have a different view of the Force. Not in terms of Jedi or Dark Jedi—of black and white, as it were—but in a way I like to think of as a full-color rainbow."

warriorcat's Avatar


warriorcat
10.05.2012 , 08:55 AM | #60
Quote: Originally Posted by morfius View Post
In game system to do what exactly?
Nobody mentioned this setting and how it affect stuttering, find above was from months ago.

Edit, since 1.4 I have a white square at 1/4 of my screen on any logoff that disappear after 2 seconds.
Not a big deal but very strange.
in your post you said something about shaderset if you open the spoiler tags to my example and find my shaderset it is ay 9 so google is asking you to change that but if you go into prefrances in game and says shadows off ( it is either at 0 or 1 anyway

Cerimon's post is still valid and worked for a few ppl the things he has said are correct :P

http://imageshack.us/a/img59/3662/se...wshadowset.png <- this is basicly the settings that will give you best performance ... and all that file is asking you to change in that .ini

Quote: Originally Posted by morfius View Post
I have it set almost same as shot provided except anti-aliasing on High (80 - 100 FPS), maybe I didn't ask it correct, my idea was is it a way to disable only shadows (settings - shadows off doesn't do it completely, they are still present in nameplates - so we got stuttering), not all mentioned in post above, lights, shaders, reflections, bloom, dept.

If is not obvious English is not my native language
http://imageshack.us/a/img696/9845/nameplateshadow.png this is what mine looks likes i am not 100% but i guess you mean titles but i dont see this causing much lag as not much of a shadow , i dont notice name plate shadows and atm it is not affecting my fps (testing ill get back to you)
Aim the rockets at Tomb of Freedom Nadd!
Level 50's Darkri/Zeraya//Jess'e char slots used 11/12
level 55 Raffes